]> git.pld-linux.org Git - packages/perl-Crypt-OpenSSL-DSA.git/blob - perl-Crypt-OpenSSL-DSA.spec
perl 5.38.0 rebuild
[packages/perl-Crypt-OpenSSL-DSA.git] / perl-Crypt-OpenSSL-DSA.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %define         pdir    Crypt
6 %define         pnam    OpenSSL-DSA
7 Summary:        Crypt::OpenSSL::DSA - Digital Signature Algorithm using OpenSSL
8 Summary(pl.UTF-8):      Crypt::OpenSSL::DSA - algorytm DSA używający OpenSSL
9 Name:           perl-Crypt-OpenSSL-DSA
10 Version:        0.20
11 Release:        5
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  8f11ba8db9dfbfff37a5df677af02538
17 URL:            https://metacpan.org/dist/Crypt-OpenSSL-DSA
18 BuildRequires:  openssl-devel >= 0.9.7d
19 BuildRequires:  openssl-tools
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRequires:  rpmbuild(macros) >= 1.745
23 BuildRequires:  which
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Crypt::OpenSSL::DSA implements the DSA (Digital Signature Algorithm)
28 signature verification system.
29
30 %description -l pl.UTF-8
31 Moduł Crypt::OpenSSL::DSA jest implementacją systemu weryfikacji
32 podpisów DSA (Digital Signature Algorithm).
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make} \
41         CC="%{__cc}" \
42         OPTIMIZE="%{rpmcflags}"
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Crypt/OpenSSL/DSA/Signature.pod
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %{perl_vendorarch}/Crypt/OpenSSL/DSA.pm
61 %dir %{perl_vendorarch}/auto/Crypt/OpenSSL/DSA
62 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/OpenSSL/DSA/DSA.so
63 %{_mandir}/man3/Crypt::OpenSSL::DSA*.3pm*
This page took 0.101331 seconds and 4 git commands to generate.