]> git.pld-linux.org Git - packages/perl-Crypt-GPG.git/blob - perl-Crypt-GPG.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Crypt-GPG.git] / perl-Crypt-GPG.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test"
4 #
5 %define         pdir    Crypt
6 %define         pnam    GPG
7 Summary:        Crypt::GPG Perl module - an object oriented interface to GnuPG
8 Summary(pl.UTF-8):      Moduł Perla Crypt::GPG - obiektowo zorientowany interfejs do GnuPG
9 Name:           perl-Crypt-GPG
10 Version:        1.63
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  9a2ab2edf9740cfef789f17c998f3fe2
17 URL:            http://search.cpan.org/dist/Crypt-GPG/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  perl-Expect >= 1.15
20 BuildRequires:  perl-TimeDate
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 The Crypt::GPG module provides near complete access to GnuPG
27 functionality through an object oriented interface. It provides
28 methods for encryption, decryption, signing, signature verification,
29 key generation, key export and import, and most other key management
30 functions. This module works almost identically to its cousin,
31 Crypt::PGP5. The two modules together provide a uniform interface to
32 deal with both PGP and GnuPG. Eventually, these modules will be folded
33 into a single module which will interface with GnuPG as well as all
34 versions of PGP.
35
36 %description -l pl.UTF-8
37 Moduł Crypt::GPG daje prawie całkowity dostęp do funkcjonalności GnuPG
38 poprzez zorientowany obiektowo interfejs. Udostępnia metody do
39 szyfrowania, odszyfrowywania, podpisywania, weryfikacji podpisów,
40 generowania kluczy, eksportowania i importowania kluczy oraz wielu
41 innych funkcji związanych z zarządzaniem kluczami. Ten moduł działa
42 prawie identycznie jak jego kuzyn, Crypt::PGP5. Oba moduły razem dają
43 jednolity interfejs do obsługi PGP i GnuPG. Być może te zostaną one
44 połączone w jeden moduł, będący interfejsem jednocześnie do GnuPG i
45 wszystkich wersji PGP.
46
47 %prep
48 %setup -q -n %{pdir}-%{pnam}-%{version}
49
50 %build
51 %{__perl} Makefile.PL \
52         INSTALLDIRS=vendor
53 %{__make}
54 # test disabled by default - it calls gpg, creates keyring etc.
55 %{?with_tests:%{__make} test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc README
69 %{perl_vendorlib}/Crypt/GPG.pm
70 %{_mandir}/man3/*
This page took 0.069831 seconds and 3 git commands to generate.