]> git.pld-linux.org Git - packages/perl-Crypt-CBC.git/blob - perl-Crypt-CBC.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Crypt-CBC.git] / perl-Crypt-CBC.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Crypt
6 %define         pnam    CBC
7 Summary:        Crypt::CBC - encrypt data with Cipher Block Chaining mode
8 Summary(pl.UTF-8):      Crypt::CBC - szyfrowanie danych w trybie Cipher Block Chaining
9 Name:           perl-Crypt-CBC
10 Version:        2.33
11 Release:        1
12 License:        Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  3db5117d60df67e3b400fe367e716be0
16 Patch0:         %{name}-paths.patch
17 URL:            http://search.cpan.org/dist/Crypt-CBC/
18 BuildRequires:  perl-Digest-MD5 >= 2.00
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Crypt-Blowfish
23 BuildRequires:  perl-Crypt-Blowfish_PP
24 BuildRequires:  perl-Crypt-DES
25 BuildRequires:  perl-Crypt-CAST5
26 BuildRequires:  perl-Crypt-IDEA
27 BuildRequires:  perl-Crypt-Rijndael
28 %endif
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 This module is a Perl-only implementation of the cryptographic cipher
34 block chaining mode (CBC). In combination with a block cipher such as
35 DES or IDEA, you can encrypt and decrypt messages of arbitrarily long
36 length. The encrypted messages are compatible with the encryption
37 format used by SSLeay.
38
39 %description -l pl.UTF-8
40 Ten moduł jest czysto perlową implementacją szyfrowania w trybie CBC
41 (Cipher Block Chaining). W połączeniu z szyfrem blokowym, takim jak
42 DES lub IDEA, pozwala szyfrować i deszyfrować wiadomości o dowolnej
43 długości. Zaszyfrowane wiadomości są kompatybilne z formatem używanym
44 przez SSLeay.
45
46 %prep
47 %setup -q -n %{pdir}-%{pnam}-%{version}
48 %patch0 -p1
49
50 %build
51 %{__perl} Makefile.PL \
52         INSTALLDIRS=vendor
53 %{__make}
54
55 %{?with_tests:%{__make} test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
60
61 %{__make} install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 install eg/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc Changes README
72 %{perl_vendorlib}/Crypt/CBC.pm
73 %{_mandir}/man3/Crypt::CBC.3pm*
74 %dir %{_examplesdir}/%{name}-%{version}
75 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*
This page took 0.104682 seconds and 4 git commands to generate.