]> git.pld-linux.org Git - packages/perl-Crypt-Blowfish_PP.git/blob - perl-Crypt-Blowfish_PP.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Crypt-Blowfish_PP.git] / perl-Crypt-Blowfish_PP.spec
1 %define         pdir    Crypt
2 %define         pnam    Blowfish_PP
3 Summary:        Crypt::Blowfish_PP Perl module - pure Perl Blowfish alghoritm implementation
4 Summary(pl.UTF-8):      Moduł Perla Crypt::Blowfish_PP - implementacja algorytmu Blowfish w samym Perlu
5 Name:           perl-Crypt-Blowfish_PP
6 Version:        1.12
7 Release:        4
8 License:        GPL or Artistic
9 Group:          Development/Languages/Perl
10 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
11 # Source0-md5:  6bf7dc80967eaf3047b67b26b015267d
12 URL:            http://search.cpan.org/dist/Crypt-Blowfish_PP/
13 BuildRequires:  perl-devel >= 1:5.8.0
14 BuildRequires:  rpm-perlprov >= 4.1-13
15 BuildArch:      noarch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 The Crypt::Blowfish_PP module provides for users to use the Blowfish
20 encryption algorithm in Perl. The implementation is entirely Object
21 Oriented, as there is quite a lot of context inherent in making
22 Blowfish as fast as it is. The key is anywhere between 64 and 448 bits
23 (8 and 56 bytes), and should be passed as a packed string. The
24 transformation itself is a 16-round Feistel Network, and operates on a
25 64 bit block.
26
27 %description -l pl.UTF-8
28 Moduł Crypt::Blowfish_PP pozwala na korzystanie z algorytmu
29 szyfrowania Blowfish w samym Perlu. Implementacja jest w pełni
30 zorientowana obiektowo, jako że potrzeba sporo rzeczy związanych z
31 kontekstem, aby Blowfish działał tak szybko jak działa. Klucza może
32 dowolnej długości między 64 a 448 bitów (8 i 56 bajtów) i powinien być
33 przekazany jako spakowany łańcuch. Sama transformacja jest 16-krokową
34 siecią Feistela i operuje na 64-bitowym bloku.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc CHANGELOG README
56 %{perl_vendorlib}/Crypt/Blowfish_PP.pm
57 %{_mandir}/man3/Crypt::Blowfish_PP.3pm*
This page took 0.050425 seconds and 4 git commands to generate.