]> git.pld-linux.org Git - packages/perl-Convert-Scalar.git/blob - perl-Convert-Scalar.spec
perl 5.38.0 rebuild
[packages/perl-Convert-Scalar.git] / perl-Convert-Scalar.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Convert
6 %define         pnam    Scalar
7 Summary:        Convert::Scalar - convert between different representations of perl scalars
8 Summary(pl.UTF-8):      Convert::Scalar - konwersja między różnymi reprezentacjami perlowych skalarów
9 Name:           perl-Convert-Scalar
10 Version:        1.04
11 Release:        16
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  849a207e94b7714c677f476608418199
17 URL:            http://search.cpan.org/dist/Convert-Scalar/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This module exports various internal perl methods that change the
24 internal representation or state of a perl scalar. All of these work
25 in-place, that is, they modify their scalar argument.
26
27 %description -l pl.UTF-8
28 Ten moduł eksportuje różne wewnętrzne perlowe metody zmieniające
29 wewnętrzną reprezentację lub stan perlowego skalara. Wszystko to
30 działa "na miejscu", czyli modyfikowany jest argument skalarny.
31
32 %prep
33 %setup -q -n %{pdir}-%{pnam}-%{version}
34
35 %build
36 %{__perl} Makefile.PL \
37         INSTALLDIRS=vendor
38
39 %{__make} \
40         CC="%{__cc}" \
41         OPTIMIZE="%{rpmcflags}"
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes
57 %{perl_vendorarch}/Convert/Scalar.pm
58 %dir %{perl_vendorarch}/auto/Convert/Scalar
59 %attr(755,root,root) %{perl_vendorarch}/auto/Convert/Scalar/Scalar.so
60 %{_mandir}/man3/*
This page took 0.118161 seconds and 4 git commands to generate.