]> git.pld-linux.org Git - packages/perl-Config-AutoConf.git/blob - perl-Config-AutoConf.spec
- new
[packages/perl-Config-AutoConf.git] / perl-Config-AutoConf.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 #
5 %define         pdir    Config
6 %define         pnam    AutoConf
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Config::AutoConf - A module to implement some of AutoConf macros in pure Perl
9 Summary(pl.UTF-8):      Config::AutoConf - moduł implementujący część makr AutoConfa w czystym Perlu
10 Name:           perl-Config-AutoConf
11 Version:        0.317
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Config/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  29f87fc7803f1725f6daafcf416089ce
18 URL:            https://metacpan.org/release/Config-AutoConf/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Capture-Tiny
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Config::AutoConf is intended to provide the same opportunities to Perl
29 developers as GNU Autoconf does for Shell developers.
30
31 As Perl is the second most deployed language (mind: every Unix comes
32 with Perl, several mini-computers have Perl and even lot's of Windows
33 machines run Perl software - which requires deployed Perl there, too),
34 this gives wider support than Shell based probes.
35
36 The API is leaned against GNU Autoconf, but we try to make the API
37 (especially optional arguments) more Perl'ish than m4 abilities allow
38 to the original.
39
40 %description -l pl.UTF-8
41 Config::AutoConf ma na celu udostępnienie programistom Perla tych
42 samych możliwości, jakie GNU Autoconf udostępnia programistom powłoki.
43
44 Jako że Perl jest drugim najczęściej wdrażanym językiem (a konkretnie:
45 każdy Unix jest dostarczany z Perlem, niektóre minikomputery mają
46 Perla, nawet wiele komputerów z Windows uruchamia oprogramowanie w
47 Perlu - co oznacza, że też zawiera Perla), co daje szerszą obsługę,
48 niż ma uniksowa powłoka.
49
50 API jest oparte na GNU Autoconfie, ale z próbą uczynienia go
51 (zwłaszcza argumentów opcjonalnych) bardziej perlowym, niż pozwalają
52 na to możliwości m4.
53
54 %prep
55 %setup -q -n %{pdir}-%{pnam}-%{version}
56
57 %build
58 %{__perl} Makefile.PL \
59         INSTALLDIRS=vendor
60 %{__make}
61
62 %{?with_tests:%{__make} test}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} pure_install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc Changes LICENSE
76 %{perl_vendorlib}/Config/AutoConf.pm
77 %{_mandir}/man3/Config::AutoConf.3pm*
This page took 0.116727 seconds and 4 git commands to generate.