]> git.pld-linux.org Git - packages/perl-Config-Any.git/blob - perl-Config-Any.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Config-Any.git] / perl-Config-Any.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    Config
6 %define pnam    Any
7 Summary:        Config::Any - Load configuration from different file formats, transparently
8 Summary(pl.UTF-8):      Config::Any - przezroczyste wczytywanie konfiguracji z różnych formatów plików
9 Name:           perl-Config-Any
10 Version:        0.23
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Config/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  97a303ef7426e5b6888bb7dd294a7e7a
17 URL:            http://search.cpan.org/dist/Config-Any/
18 BuildRequires:  perl-Module-Build
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Config-General
23 BuildRequires:  perl-Config-Tiny
24 BuildRequires:  perl-JSON
25 BuildRequires:  perl-Module-Pluggable >= 3.01
26 BuildRequires:  perl-XML-Simple
27 BuildRequires:  perl-YAML
28 BuildRequires:  perl-version
29 %endif
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Config::Any provides a facility for Perl applications and libraries
35 to load configuration data from multiple different file formats. It
36 supports XML, YAML, JSON, Apache-style configuration, Windows INI
37 files, and even Perl code.
38
39 The rationale for this module is as follows: Perl programs are deployed
40 on many different platforms and integrated with many different
41 systems. Systems administrators and end users may prefer different
42 configuration formats than the developers. The flexibility inherent
43 in a multiple format configuration loader allows different users
44 to make different choices, without generating extra work for the
45 developers. As a developer you only need to learn a single interface
46 to be able to use the power of different configuration formats.
47
48 %description -l pl.UTF-8
49 Config::Any ułatwia aplikacjom i bibliotekom perlowym wczytywanie
50 danych konfiguracyjnych z wielu różnych formatów plików. Obsługuje
51 XML, YAML, JSON, konfigurację w stylu Apache'a, pliki Windows INI, a
52 nawet kod perlowy.
53
54 Uzasadnienie istnienia tego modułu jest takie, że programy w Perlu są
55 wdrażane na wielu różnych platformach i integrowane z wieloma różnymi
56 systemami. Administratorzy i użytkownicy końcowi mogą preferować inne
57 formaty konfiguracyjne niż programiści. Elastyczność tkwiąca w
58 możliwości wczytywania wielu formatów pozwala różnym użytkownikom
59 dokonywać różnych wyborów bez generowania dodatkowej pracy dla
60 programistów. Wystarczy, że programista nauczy się jednego interfejsu
61 i może wykorzystać potęgę różnych formatów konfiguracji.
62
63 %prep
64 %setup -q -n %{pdir}-%{pnam}-%{version}
65
66 %build
67 %{__perl} Makefile.PL \
68         installdirs=vendor
69 %{__make}
70
71 %{?with_tests:%{__make} test}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 %{__make} install \
77         DESTDIR=$RPM_BUILD_ROOT
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files
83 %defattr(644,root,root,755)
84 %doc Changes README
85 %{perl_vendorlib}/Config/*.pm
86 %{perl_vendorlib}/Config/Any
87 %{_mandir}/man3/*
This page took 0.072949 seconds and 4 git commands to generate.