]> git.pld-linux.org Git - packages/perl-Compress-Raw-Lzma.git/blob - perl-Compress-Raw-Lzma.spec
perl 5.38.0 rebuild
[packages/perl-Compress-Raw-Lzma.git] / perl-Compress-Raw-Lzma.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 #
5 %define         pdir    Compress
6 %define         pnam    Raw-Lzma
7 Summary:        Compress::Raw::Lzma - low-level Interface to lzma compression library
8 Summary(pl.UTF-8):      Compress::Raw::Lzma - niskopoziomowy interfejs do biblioteki kompresji lzma
9 Name:           perl-Compress-Raw-Lzma
10 Version:        2.201
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        https://www.cpan.org/modules/by-module/Compress/Compress-Raw-Lzma-%{version}.tar.gz
16 # Source0-md5:  366a7fbb946cd2be6a60e69123b62f5e
17 URL:            https://metacpan.org/dist/Compress-Raw-Lzma
18 BuildRequires:  perl-ExtUtils-MakeMaker >= 5.16
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.745
22 BuildRequires:  xz-devel
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Compress::Raw::Lzma provides an interface to the in-memory
27 compression/uncompression functions from the lzma compression library.
28
29 Although the primary purpose for the existence of Compress::Raw::Lzma
30 is for use by the IO::Compress::Lzma, IO::Uncompress::UnLzma,
31 IO::Compress::Xz and IO::Uncompress::UnXz modules, it can be used on
32 its own for simple compression/uncompression tasks.
33
34 %description -l pl.UTF-8
35 Compress::Raw::Lzma udostępnia interfejs do funkcji kompresji i
36 dekompresji w pamięci biblioteki kompresji lzma.
37
38 Mimo że głównym celem istnienia modułu Compres::Raw::Lzma jest
39 wykorzystywanie przez moduły IO::Compres::Lzma,
40 IO::Uncompress::UnLzma, IO::Compress::Xz i IO::Uncompress::UnXz, może
41 być używany także samodzielnie do prostych zadań
42 kompresji/dekompresji.
43
44 %prep
45 %setup -q -n %{pdir}-%{pnam}-%{version}
46
47 %build
48 %{__perl} Makefile.PL \
49         INSTALLDIRS=vendor
50 %{__make} \
51         CC="%{__cc}" \
52         OPTIMIZE="%{rpmcflags}"
53
54 %{?with_tests:%{__make} test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} pure_install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc Changes
68 %{perl_vendorarch}/Compress/Raw/Lzma.pm
69 %dir %{perl_vendorarch}/auto/Compress/Raw/Lzma
70 %{perl_vendorarch}/auto/Compress/Raw/Lzma/autosplit.ix
71 %attr(755,root,root) %{perl_vendorarch}/auto/Compress/Raw/Lzma/Lzma.so
72 %{_mandir}/man3/Compress::Raw::Lzma.3pm*
This page took 0.123281 seconds and 3 git commands to generate.