]> git.pld-linux.org Git - packages/perl-Compress-LZF.git/blob - perl-Compress-LZF.spec
perl 5.38.0 rebuild
[packages/perl-Compress-LZF.git] / perl-Compress-LZF.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Compress
6 %define         pnam    LZF
7 Summary:        Compress::LZF Perl module - extremely leight-weight Lev-Zimpel-Free compression
8 Summary(pl.UTF-8):      Moduł Perla Compress::LZF - ekstremalnie lekka kompresja Lev-Zimpel-Free
9 Name:           perl-Compress-LZF
10 %define srcver  3.8
11 Version:        %{srcver}0
12 Release:        7
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Compress/%{pdir}-%{pnam}-%{srcver}.tar.gz
17 # Source0-md5:  c6c4c09d288fd040782eb7edfc39b015
18 URL:            https://metacpan.org/dist/Compress-LZF
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.745
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 LZF is an extremely fast (not that much slower than a pure memcpy)
26 compression algorithm. It is ideal for applications where you want to
27 save *some* space but not at the cost of speed. It is ideal for
28 repetitive data as well. The module is self-contained and very small
29 (no large library to be pulled in). It is also free, so there should
30 be no problems incoporating this module into commercial programs. It
31 is believed that it is free from any patents.
32
33 %description -l pl.UTF-8
34 LZF jest ekstremalnie szybkim (nie tak dużo wolniejszym od memcpy)
35 algorytmem kompresji. Jest idealny dla programów, które chcą
36 zaoszczędzić *trochę* miejsca, ale nie kosztem szybkości. Jest idealny
37 dla powtarzających się danych. Moduł jest mały i nie wymaga żadnej
38 dodatkowej dużej biblioteki. Jest wolnodostępny, więc nie powinno być
39 problemów z wykorzystaniem go w komercyjnych programach. Według
40 aktualnego stanu wiedzy jest wolny od patentów.
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{srcver}
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48 %{__make} \
49         CC="%{__cc}" \
50         OPTIMIZE="%{rpmcflags}"
51
52 %{?with_tests:%{__make} test}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %{__make} install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc Changes README
66 %{perl_vendorarch}/Compress/LZF.pm
67 %dir %{perl_vendorarch}/auto/Compress/LZF
68 %attr(755,root,root) %{perl_vendorarch}/auto/Compress/LZF/LZF.so
69 %{_mandir}/man3/Compress::LZF.3pm*
This page took 0.213992 seconds and 4 git commands to generate.