]> git.pld-linux.org Git - packages/perl-Clone.git/blob - perl-Clone.spec
- updated URL
[packages/perl-Clone.git] / perl-Clone.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 #
5 %define         pdir    Clone
6 Summary:        Clone - Perl module for recursively copying Perl datatypes
7 Summary(pl.UTF-8):      Clone - moduł Perla obsługujący rekursywne kopiowanie zmiennych w Perlu
8 Name:           perl-Clone
9 Version:        0.46
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Clone/%{pdir}-%{version}.tar.gz
15 # Source0-md5:  cafa8984a2c2e005e54b27dd1e3f0afe
16 URL:            https://metacpan.org/release/Clone
17 %if %{with tests}
18 BuildRequires:  perl-B-COW >= 0.004
19 BuildRequires:  perl-Test-Simple >= 0.88
20 %endif
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildRequires:  rpmbuild(macros) >= 1.745
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This module provides a clone() method which makes recursive copies
28 of nested hash, array, scalar and reference types, including tied
29 variables and objects.
30
31 %description -l pl.UTF-8
32 Ten moduł dostarcza clone(), metodę służącą do rekurencyjnego
33 kopiowania zagnieżdżonych tablic asocjacyjnych, tablic, skalarów i
34 referencji, włącznie ze związanymi zmiennymi i obiektami.
35
36 %prep
37 %setup -q -n %{pdir}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42
43 %{__make} \
44         CC="%{__cc}" \
45         OPTIMIZE="%{rpmcflags}"
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes
61 %{perl_vendorarch}/Clone.pm
62 %attr(755,root,root) %{perl_vendorarch}/auto/Clone/Clone.so
63 %{perl_vendorarch}/auto/Clone/autosplit.ix
64 %{_mandir}/man3/Clone.3pm*
This page took 0.139907 seconds and 3 git commands to generate.