]> git.pld-linux.org Git - packages/perl-Class-Trigger.git/blob - perl-Class-Trigger.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Class-Trigger.git] / perl-Class-Trigger.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Class
6 %define         pnam    Trigger
7 Summary:        Class:Trigger - mixin to add / call inheritable triggers
8 Summary(pl.UTF-8):      Class:Trigger - dodawanie / wołanie wyzwalaczy umożliwiających dziedziczenie
9 Name:           perl-Class-Trigger
10 Version:        0.14
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Class/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  b0a95ebe359a3c4e768d81fc58031c83
17 URL:            http://search.cpan.org/dist/Class-Trigger/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Class-Data-Inheritable
22 BuildRequires:  perl-IO-stringy
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Class::Trigger is a mixin class to add / call triggers (or hooks) that
29 get called at some points you specify.
30
31 %description -l pl.UTF-8
32 Class::Trigger jest klasą służącą do dodawania i wywoływania
33 wyzwalaczy (lub hooków), które są wywoływane w podanych miejscach.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make}
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc Changes
56 %{perl_vendorlib}/Class/Trigger.pm
57 %{_mandir}/man3/Class::Trigger.3pm*
This page took 0.140351 seconds and 4 git commands to generate.