]> git.pld-linux.org Git - packages/perl-Class-Std.git/blob - perl-Class-Std.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Class-Std.git] / perl-Class-Std.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define pdir    Class
6 %define pnam    Std
7 Summary:        Class::Std - Support for creating standard "inside-out" classes
8 Name:           perl-Class-Std
9 Version:        0.0.9
10 Release:        1
11 License:        GPL
12 Group:          Development/Languages/Perl
13 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
14 # Source0-md5:  376e009ce786d7f1887b212d6582e63f
15 URL:            http://search.cpan.org/dist/Class-Std/
16 BuildRequires:  perl-modules >= 1:5.8.8
17 BuildRequires:  perl-version >= 0.44
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This module provides tools that help to implement the "inside out
24 object" class structure in a convenient and standard way.
25
26 %prep
27 %setup -q -n %{pdir}-%{pnam}-%{version}
28
29 %build
30 %{__perl} Makefile.PL \
31         INSTALLDIRS=vendor
32 %{__make}
33
34 %{?with_tests:%{__make} test}
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38
39 %{__make} install \
40         DESTDIR=$RPM_BUILD_ROOT
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %files
46 %defattr(644,root,root,755)
47 %doc Changes README
48 %{perl_vendorlib}/Class/*.pm
49 %{_mandir}/man3/*
This page took 0.0787 seconds and 4 git commands to generate.