]> git.pld-linux.org Git - packages/perl-Class-ReturnValue.git/blob - perl-Class-ReturnValue.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Class-ReturnValue.git] / perl-Class-ReturnValue.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test"
4
5 %define         pdir    Class
6 %define         pnam    ReturnValue
7 Summary:        Class::ReturnValue - a return-value object that may be treated as a boolean, array or object
8 Summary(pl.UTF-8):      Class::ReturnValue - obiekt wartości zwracanej, który może być traktowany jak wartość logiczna, tablica lub obiekt
9 Name:           perl-Class-ReturnValue
10 Version:        0.55
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  047fbbcfd90d5c399a1feba55781329e
17 URL:            http://search.cpan.org/dist/Class-ReturnValue/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Class::ReturnValue is a "clever" return value object that can allow
25 code calling your routine to expect: a boolean value (did it fail) or
26 a list (what are the return values).
27
28 %description -l pl.UTF-8
29 Class::ReturnValue jest ,,mądrym'' obiektem, który pozwala, aby kod
30 wywołujący Twoje funkcje oczekiwał: wartości boolowskiej (czy się
31 udało) lub listy (jakie wartości zwrócono).
32
33 %prep
34 %setup -q -n %{pdir}-%{pnam}-%{version}
35 #%{__perl} -pi -e 'BEGIN{undef $/};s/\{\s*package MY;.*$//s' Makefile.PL
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make}
41 # Warning: test script in this package IS broken (wrong name)
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 %{__make} install \
47         DESTDIR=$RPM_BUILD_ROOT
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc Changes
55 %{perl_vendorlib}/%{pdir}/*.pm
56 %{_mandir}/man3/*
This page took 0.09704 seconds and 4 git commands to generate.