]> git.pld-linux.org Git - packages/perl-Class-MethodMaker.git/blob - perl-Class-MethodMaker.spec
perl 5.38.0 rebuild
[packages/perl-Class-MethodMaker.git] / perl-Class-MethodMaker.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Class
6 %define         pnam    MethodMaker
7 Summary:        Class::MethodMaker - a module for creating generic methods
8 Summary(pl.UTF-8):      Class::MethodMaker - moduł do tworzenia ogólnych metod
9 Name:           perl-Class-MethodMaker
10 Version:        2.24
11 Release:        7
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Class/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  6fac1ed1fea8a4e42d36a4d07c8bfa09
17 Patch0:         build.patch
18 URL:            http://search.cpan.org/dist/Class-MethodMaker/
19 %{?with_tests:BuildRequires:    perl-IPC-Run >= 0.89}
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This module solves the problem of having to write a bazillion get/set
26 methods that are all the same. The argument to 'use' is a hash whose
27 keys are the names of types of generic methods generated by
28 MethodMaker and whose values tell method maker what methods to make.
29 (More precisely, the keys are the names of MethodMaker methods
30 (methods that write methods) and the values are the arguments to those
31 methods.
32
33 %description -l pl.UTF-8
34 Ten moduł rozwiązuje problem pisania bazylionów metod get/set, które
35 są wszystkie takie same. Parametrem 'use' jest hasz, którego klucze są
36 nazwami typów do ogólnych metod, wygenerowanych przez MethodMakera, a
37 wartości mówią modułowi, które metody utworzyć (bardziej precyzyjnie:
38 klucze są nazwami metod MethodMakera (metod, które tworzą metody), a
39 wartości to parametry dla tych metod).
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43 %patch0 -p1
44 mv -f end.pod lib/Class/MethodMaker/
45
46 %build
47 %{__perl} generate.PL
48 %{__perl} -MExtUtils::MakeMaker -wle \
49         'WriteMakefile(NAME=>"Class::MethodMaker",
50         PL_FILES=>{}, VERSION=>"%{version}")' \
51         INSTALLDIRS=vendor
52
53 %{?with_tests:%{__make} test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/Class/.placeholder
62 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/Class/MethodMaker/end.pod
63 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/Class/cmmg.pl
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %{perl_vendorarch}/Class/*.pm
71 %dir %{perl_vendorarch}/Class/MethodMaker
72 %{perl_vendorarch}/Class/MethodMaker/*.pm
73 %dir %{perl_vendorarch}/auto/Class/MethodMaker
74 %{perl_vendorarch}/auto/Class/MethodMaker/array
75 %{perl_vendorarch}/auto/Class/MethodMaker/hash
76 %{perl_vendorarch}/auto/Class/MethodMaker/scalar
77 %dir %{perl_vendorarch}/auto/Class/MethodMaker/Engine
78 %{perl_vendorarch}/auto/Class/MethodMaker/Engine/*.al
79 %{perl_vendorarch}/auto/Class/MethodMaker/Engine/*.ix
80 %attr(755,root,root) %{perl_vendorarch}/auto/Class/MethodMaker/*.so
81 %{_mandir}/man3/*
This page took 0.177559 seconds and 4 git commands to generate.