]> git.pld-linux.org Git - packages/perl-Class-MakeMethods.git/blob - perl-Class-MakeMethods.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Class-MakeMethods.git] / perl-Class-MakeMethods.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Class
6 %define         pnam    MakeMethods
7 Summary:        Class::MakeMethods - generate common types of methods
8 Summary(pl.UTF-8):      Class::MakeMethods - generowanie ogólnych typów metod
9 Name:           perl-Class-MakeMethods
10 Version:        1.01
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  838c98dcf1b1fff4c5d8cffaec32ebbb
17 URL:            http://search.cpan.org/dist/Class-MakeMethods/
18 %if %{with tests}
19 BuildRequires:  perl-Test-Simple
20 %endif
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 Provides:       %{name}-Template = 1.005
24 Obsoletes:      perl-Class-MakeMethods-Template < 1.005
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 # this belongs to unfinished code - we have no choice...
29 %define         _noautoreq      'perl(Class::MakeMethods::Template::Array)'
30
31 %description
32 The Class::MakeMethods framework allows Perl class developers to
33 quickly define common types of methods. When a module uses a subclass
34 of Class::MakeMethods, it can select from the supported method types,
35 and specify a name for each method desired. The methods are
36 dynamically generated and installed in the calling package.
37
38 %description -l pl.UTF-8
39 Szkielet Class::MakeMethods umożliwia deweloperom Perla szybkie
40 definiowanie ogólnych typów metod. Gdy moduł korzysta z podklasy klasy
41 Class::MakeMethods, może on dokonywać wyboru spośród wspieranych typów
42 metod i podaje nazwę każdej z żądanych metod. Metody są generowane
43 dynamicznie i instalowane w pakiecie, który je wywołuje.
44
45 %prep
46 %setup -q -n %{pdir}-%{pnam}-%{version}
47 %{__perl} -pi -e 's/^(require 5.003)(07;)(.*)$/$1_$2$3/' MakeMethods.pm
48
49 %build
50 %{__perl} Makefile.PL \
51         INSTALLDIRS=vendor
52 %{__make}
53 %{?with_tests:%{__make} test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %{perl_vendorlib}/Class/MakeMethods.pm
67 %dir %{perl_vendorlib}/Class/MakeMethods
68 %{perl_vendorlib}/Class/MakeMethods/*.pm
69 %{perl_vendorlib}/Class/MakeMethods/Basic
70 %{perl_vendorlib}/Class/MakeMethods/Composite
71 %{perl_vendorlib}/Class/MakeMethods/Emulator
72 %{perl_vendorlib}/Class/MakeMethods/Evaled
73 %{perl_vendorlib}/Class/MakeMethods/Standard
74 %{perl_vendorlib}/Class/MakeMethods/Template
75 %{perl_vendorlib}/Class/MakeMethods/Utility
76 %{_mandir}/man3/*
This page took 0.07059 seconds and 4 git commands to generate.