]> git.pld-linux.org Git - packages/perl-Class-Inner.git/blob - perl-Class-Inner.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Class-Inner.git] / perl-Class-Inner.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Class
6 %define         pnam    Inner
7 Summary:        Class::Inner - a perlish implementation of Java-like inner classes
8 Summary(pl.UTF-8):      Class::Inner - perlowa implementacja wewnętrznych klas w stylu Javy
9 Name:           perl-Class-Inner
10 Version:        0.1
11 Release:        4
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  388db813c6a7050c4e0483bc4d86fc21
17 URL:            http://search.cpan.org/dist/Class-Inner/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Yet another implementation of an anonymous class with per object
25 overrideable methods, but with the added attraction of sort of working
26 dispatch to the parent class's method.
27
28 %description -l pl.UTF-8
29 Jeszcze jedna implementacja anonimowej klasy z metodami przykrywalnymi
30 dla obiektu, ale z dodanym czymś w rodzaju wysyłania do metody klasy
31 nadrzędnej.
32
33 %prep
34 %setup -q -n %{pdir}-%{pnam}-%{version}
35
36 %build
37 %{__perl} Makefile.PL \
38         INSTALLDIRS=vendor
39 %{__make}
40
41 %{?with_tests:%{__make} test}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 %{__make} install \
47         DESTDIR=$RPM_BUILD_ROOT
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc Changes README
55 %{perl_vendorlib}/%{pdir}/%{pnam}.pm
56 %{_mandir}/man3/*
This page took 0.069559 seconds and 4 git commands to generate.