]> git.pld-linux.org Git - packages/perl-Class-DBI-SQLite.git/blob - perl-Class-DBI-SQLite.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Class-DBI-SQLite.git] / perl-Class-DBI-SQLite.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Class
6 %define         pnam    DBI-SQLite
7 Summary:        Extension to Class::DBI for SQLite
8 Summary(pl.UTF-8):      Rozszerzenie Class::DBI dla SQLite
9 Name:           perl-Class-DBI-SQLite
10 Version:        0.11
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  25e80b9d2f2d66e6fc51d487f0894802
17 URL:            http://search.cpan.org/dist/Class-DBI-SQLite/
18 %if %{with tests}
19 BuildRequires:  perl-Class-DBI >= 0.85
20 BuildRequires:  perl-DBD-SQLite >= 0.07
21 BuildRequires:  perl-Ima-DBI >= 0.27
22 BuildRequires:  perl-SQL-Statement >= 1.004
23 %endif
24 BuildRequires:  perl-devel >= 1:5.8.0
25 BuildRequires:  rpm-perlprov >= 4.1-13
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Class::DBI::SQLite is an extension to Class::DBI for DBD::SQLite,
31 which allows you to populate auto incremented row id after insert.
32 set_up_table method allows you to automate the setup of columns and
33 primary key by using of SQLite PRAGMA statement (with SQL::Statement
34 module).
35
36 %description -l pl.UTF-8
37 Class::DBI::SQLite to rozszerzenie Class::DBI dla DBD::SQLite,
38 pozwalające wypełniać automatycznie zwiększany identyfikator wiersza
39 po instrukcji INSERT. Metoda set_up_table pozwala zautomatyzować
40 ustawianie kolumn i klucza głównego poprzez użycie instrukcji SQLite
41 PRAGMA (przy użyciu modułu SQL::Statement).
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49
50 %{__make}
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc Changes
65 %{perl_vendorlib}/Class/DBI/SQLite.pm
66 %{_mandir}/man3/*
This page took 0.076229 seconds and 4 git commands to generate.