3 %bcond_without tests # do not perform "make test"
6 %define pnam DBI-SQLite
7 Summary: Extension to Class::DBI for SQLite
8 Summary(pl.UTF-8): Rozszerzenie Class::DBI dla SQLite
9 Name: perl-Class-DBI-SQLite
13 License: GPL v1+ or Artistic
14 Group: Development/Languages/Perl
15 Source0: http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5: 25e80b9d2f2d66e6fc51d487f0894802
17 URL: http://search.cpan.org/dist/Class-DBI-SQLite/
19 BuildRequires: perl-Class-DBI >= 0.85
20 BuildRequires: perl-DBD-SQLite >= 0.07
21 BuildRequires: perl-Ima-DBI >= 0.27
22 BuildRequires: perl-SQL-Statement >= 1.004
24 BuildRequires: perl-devel >= 1:5.8.0
25 BuildRequires: rpm-perlprov >= 4.1-13
27 BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30 Class::DBI::SQLite is an extension to Class::DBI for DBD::SQLite,
31 which allows you to populate auto incremented row id after insert.
32 set_up_table method allows you to automate the setup of columns and
33 primary key by using of SQLite PRAGMA statement (with SQL::Statement
36 %description -l pl.UTF-8
37 Class::DBI::SQLite to rozszerzenie Class::DBI dla DBD::SQLite,
38 pozwalające wypełniać automatycznie zwiększany identyfikator wiersza
39 po instrukcji INSERT. Metoda set_up_table pozwala zautomatyzować
40 ustawianie kolumn i klucza głównego poprzez użycie instrukcji SQLite
41 PRAGMA (przy użyciu modułu SQL::Statement).
44 %setup -q -n %{pdir}-%{pnam}-%{version}
47 %{__perl} Makefile.PL \
51 %{?with_tests:%{__make} test}
54 rm -rf $RPM_BUILD_ROOT
57 DESTDIR=$RPM_BUILD_ROOT
60 rm -rf $RPM_BUILD_ROOT
63 %defattr(644,root,root,755)
65 %{perl_vendorlib}/Class/DBI/SQLite.pm