]> git.pld-linux.org Git - packages/perl-Class-Container.git/blob - perl-Class-Container.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Class-Container.git] / perl-Class-Container.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Class
6 %define         pnam    Container
7 Summary:        Class::Container - glues object frameworks together transparently
8 Summary(pl.UTF-8):      Class::Container - przezroczyste sklejanie szkieletów obiektów
9 Name:           perl-Class-Container
10 Version:        0.13
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  5321b227c09c96911a8a0ce269bbfd36
17 URL:            http://search.cpan.org/dist/Class-Container/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Params-Validate >= 0.18
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         _noautoreq      'perl(Scalar::Util)'
27
28 %description
29 This class facilitates building frameworks of several classes that
30 inter-operate. It was first designed and built for "HTML::Mason", in
31 which the Compiler, Lexer, Interpreter, Resolver, Component, Buffer,
32 and several other objects must create each other transparently,
33 passing the appropriate parameters to the right class, possibly
34 substituting their own subclass for any of these objects.
35
36 %description -l pl.UTF-8
37 Ta klasa ułatwia tworzenie szkieletu dla różnych, współpracujących ze
38 sobą, klas. Pierwotnie była zaprojektowana i stworzona dla
39 HTML::Mason, w którym Compiler, Lexer, Interpreter, Resolver,
40 Component, Buffer i kilka innych obiektów muszą tworzyć inne w sposób
41 przezroczysty, przekazując odpowiednie parametry do właściwej klasy,
42 być może także podstawiając swoją własną podklasę za dowolny z tych
43 obiektów.
44
45 %prep
46 %setup -q -n %{pdir}-%{pnam}-%{version}
47 # We do not sleep.
48 %{__perl} -ni -e 'print unless /sleep/' Makefile.PL
49
50 %build
51 %{__perl} Makefile.PL \
52         INSTALLDIRS=vendor
53 %{__make}
54
55 %{?with_tests:%{__make} test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc Changes README
69 %{perl_vendorlib}/Class/Container.pm
70 %{_mandir}/man3/*.3pm*
This page took 0.153627 seconds and 4 git commands to generate.