]> git.pld-linux.org Git - packages/perl-Check-ISA.git/blob - perl-Check-ISA.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Check-ISA.git] / perl-Check-ISA.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    Check
6 %define pnam    ISA
7 Summary:        Check::ISA - DWIM, correct checking of an object's class
8 Summary(pl.UTF-8):      Check::ISA - DWIM, poprawne sprawdzanie klas obiektów
9 Name:           perl-Check-ISA
10 Version:        0.09
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/M/MA/MANWAR/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  d86bd85a04cdc0976841fdc2c6fa19b5
17 URL:            http://search.cpan.org/dist/Check-ISA/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Sub-Exporter
22 BuildRequires:  perl-Test-Simple >= 1.001014
23 #BuildRequires: perl-Test-use-ok  # included in Test::Simple >= 1.001014
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This module provides several functions to assist in testing whether a
30 value is an object, and if so asking about its class.
31
32 %description -l pl.UTF-8
33 Moduł ten dostarcza funkcje wspierające sprawdzanie, czy wartość jest
34 obiektem, i, jeśli jest, do zapytania o jego klasę.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} pure_install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes README
58 %dir %{perl_vendorlib}/Check
59 %{perl_vendorlib}/Check/ISA.pm
60 %{_mandir}/man3/Check::ISA.3pm*
This page took 0.111259 seconds and 4 git commands to generate.