]> git.pld-linux.org Git - packages/perl-Cache.git/blob - perl-Cache.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Cache.git] / perl-Cache.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define pdir    Cache
6 Summary:        Cache - the cache interface
7 Summary(pl.UTF-8):      Cache - interfejs buforujący
8 Name:           perl-Cache
9 Version:        2.04
10 Release:        2
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{version}.tar.gz
15 # Source0-md5:  c64b8dd8f04e101bd20cde0c7c2e3d17
16 URL:            http://search.cpan.org/dist/Cache/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl(Date::Parse) >= 2.24
21 BuildRequires:  perl-DB_File >= 1.72
22 BuildRequires:  perl-Digest-SHA1 >= 2.01
23 BuildRequires:  perl-File-NFSLock >= 1.2
24 BuildRequires:  perl-Heap >= 0.01
25 BuildRequires:  perl-IO-String >= 1.02
26 BuildRequires:  perl-Storable >= 1
27 BuildRequires:  perl-Test-Simple >= 0.45
28 %endif
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 The Cache modules are designed to assist a developer in persisting
34 data for a specified period of time. Often these modules are used in
35 web applications to store data locally to save repeated and redundant
36 expensive calls to remote machines or databases.
37
38 The Cache interface is implemented by derived classes that store
39 cached data in different manners (such as files on a filesystem, or in
40 memory).
41
42 %description -l pl.UTF-8
43 Moduły Cache są zaprojektowane, aby pomagać programistom w
44 przechowywaniu danych przez określony okres czasu. Zwykle moduły te są
45 używane w aplikacjach WWW do lokalnego przechowywania danych w celu
46 zaoszczędzenia powtarzających się i nadmiarowych drogich wywołań do
47 zdalnych maszyn lub baz danych.
48
49 Interfejs Cache jest zaimplementowany poprzez klasy dziedziczące
50 przechowujące buforowane dane na różne sposoby (np. w plikach albo w
51 pamięci).
52
53 %prep
54 %setup -q -n %{pdir}-%{version}
55
56 %build
57 %{__perl} Makefile.PL \
58         INSTALLDIRS=vendor
59 %{__make}
60
61 %{?with_tests:%{__make} test}
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 %{__make} install \
67         DESTDIR=$RPM_BUILD_ROOT
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc Changes LICENSE README TODO
75 %{perl_vendorlib}/*.pm
76 %{perl_vendorlib}/Cache/*
77 %{_mandir}/man3/*
This page took 0.082122 seconds and 4 git commands to generate.