]> git.pld-linux.org Git - packages/perl-CPAN-Reporter.git/blob - perl-CPAN-Reporter.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-CPAN-Reporter.git] / perl-CPAN-Reporter.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # do not perform "make test"
4 #
5 %define pdir    CPAN
6 %define pnam    Reporter
7 Summary:        CPAN::Reporter - Adds CPAN Testers reporting to CPAN.pm
8 #Summary(pl.UTF-8):     
9 Name:           perl-CPAN-Reporter
10 Version:        1.2003
11 Release:        1
12 License:        Apache
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/CPAN/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  3f705c2b1f38bd8956447043f2c557c5
16 URL:            http://search.cpan.org/dist/CPAN-Reporter/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl(File::pushd) >= 0.32
21 BuildRequires:  perl(IO::CaptureOutput) >= 1.03
22 BuildRequires:  perl(Probe::Perl)
23 BuildRequires:  perl(Tee) >= 0.13
24 BuildRequires:  perl-Config-Tiny >= 2.08
25 BuildRequires:  perl-CPAN >= 1.9203
26 BuildRequires:  perl-File-Copy-Recursive >= 0.35
27 BuildRequires:  perl-File-HomeDir >= 0.58
28 BuildRequires:  perl-Test-Reporter >= 1.34
29 %endif
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 The CPAN Testers project captures and analyses detailed results from building
35 and testing CPAN distributions on multiple operating systems and multiple
36 versions of Perl.  This provides valuable feedback to module authors and
37 potential users to identify bugs or platform compatibility issues and improves
38 the overall quality and value of CPAN.
39
40 One way individuals can contribute is to send a report for each module that
41 they test or install.  CPAN::Reporter is an add-on for the CPAN.pm module to
42 send the results of building and testing modules to the CPAN Testers project.
43
44 # %description -l pl.UTF-8
45 # TODO
46
47 %prep
48 %setup -q -n %{pdir}-%{pnam}-%{version}
49
50 %build
51 %{__perl} Makefile.PL \
52         destdir=$RPM_BUILD_ROOT \
53         installdirs=vendor
54 %{__make}
55
56 %{?with_tests:%{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} install
62
63 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
64 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc Changes
72 %{perl_vendorlib}/CPAN/*.pm
73 %{perl_vendorlib}/CPAN/Reporter
74 %{_mandir}/man3/*
75 %{_examplesdir}/%{name}-%{version}
This page took 0.071754 seconds and 4 git commands to generate.