]> git.pld-linux.org Git - packages/perl-CPAN-Changes.git/blob - perl-CPAN-Changes.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-CPAN-Changes.git] / perl-CPAN-Changes.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    CPAN
6 %define         pnam    Changes
7 Summary:        Test::CPAN::Changes - Validation of the Changes file in a CPAN distribution
8 Summary(pl.UTF-8):      Test::CPAN::Changes - sprawdzanie poprawności pliku Changes w dystrybucji CPAN
9 Name:           perl-CPAN-Changes
10 Version:        0.400002
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/CPAN/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  5773d51abaafd37c6bcdde3827873075
17 URL:            http://search.cpan.org/dist/CPAN-Changes/
18 BuildRequires:  perl-devel >= 1:5.10.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(Text::Wrap) >= 0.96
22 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.59
23 BuildRequires:  perl-Test-Simple >= 0.96
24 BuildRequires:  perl-version >= 0.9906
25 %endif
26 Requires:       perl-version >= 0.9906
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 This module allows CPAN authors to write automated tests to ensure
32 their changelogs match the specification.
33
34 %description -l pl.UTF-8
35 Ten moduł pozwala autorom CPAN tworzyć automatyczne testy sprawdzające
36 zgodność plików logów zmian ze specyfikacją.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} pure_install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %attr(755,root,root) %{_bindir}/tidy_changelog
61 %{perl_vendorlib}/CPAN/Changes.pm
62 %{perl_vendorlib}/CPAN/Changes
63 %dir %{perl_vendorlib}/Test/CPAN
64 %{perl_vendorlib}/Test/CPAN/Changes.pm
65 %{_mandir}/man1/tidy_changelog.1p*
66 %{_mandir}/man3/CPAN::Changes*.3pm*
67 %{_mandir}/man3/Test::CPAN::Changes.3pm*
This page took 0.078996 seconds and 4 git commands to generate.