]> git.pld-linux.org Git - packages/perl-CGI-Compile.git/blob - perl-CGI-Compile.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-CGI-Compile.git] / perl-CGI-Compile.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    CGI
6 %define         pnam    Compile
7 Summary:        CGI::Compile - Compile .cgi scripts to a code reference like ModPerl::Registry
8 Name:           perl-CGI-Compile
9 Version:        0.22
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/CGI/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  a6b364e8f3eb45f63d69ae6d5602eb21
16 URL:            http://search.cpan.org/dist/CGI-Compile/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl(File::pushd)
21 BuildRequires:  perl(Test::NoWarnings)
22 BuildRequires:  perl-Test-Requires
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 CGI::Compile is an utility to compile CGI scripts into a code
29 reference that can run many times on its own namespace, as long as the
30 script is ready to run on a persistent environment.
31
32 NOTE: for best results, load CGI::Compile before any modules used by
33 your CGIs.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Build.PL \
40         --destdir=$RPM_BUILD_ROOT \
41         --installdirs=vendor
42 ./Build
43
44 %{?with_tests:./Build test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 ./Build install
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes README
57 %{perl_vendorlib}/CGI/*.pm
58 %{_mandir}/man3/*
This page took 0.110781 seconds and 4 git commands to generate.