]> git.pld-linux.org Git - packages/perl-CGI-Application.git/blob - perl-CGI-Application.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-CGI-Application.git] / perl-CGI-Application.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # do perform "make test"
4
5 %define         pdir    CGI
6 %define         pnam    Application
7 Summary:        CGI::Application - framework for building reusable web-applications
8 Summary(pl.UTF-8):      CGI::Application - szkielet do tworzenia aplikacji WWW wielokrotnego użytku
9 Name:           perl-CGI-Application
10 Version:        4.50
11 Release:        2
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  356595b6f12373f57243a7e605b9cd43
16 URL:            http://search.cpan.org/dist/CGI-Application/
17 BuildRequires:  perl-Module-Build >= 0.20
18 BuildRequires:  perl-devel >= 1:5.8.0
19 %if %{with tests}
20 BuildRequires:  perl-CGI
21 BuildRequires:  perl-Class-ISA
22 BuildRequires:  perl-HTML-Template
23 BuildRequires:  perl-Test-Simple >= 0.47
24 %endif
25 BuildRequires:  rpm-build >= 4.3-0.20030515.6
26 BuildRequires:  rpm-perlprov >= 4.1-13
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 CGI::Application is intended to make it easier to create
32 sophisticated, reusable web-based applications. This module implements
33 a methodology which, if followed, will make your web software easier
34 to design, easier to document, easier to write, and easier to evolve.
35
36 %description -l pl.UTF-8
37 CGI::Application jest przeznaczony do ułatwiania tworzenia złożonych,
38 dających się ponownie wykorzystywać, aplikacji opartych na WWW. Ten
39 moduł implementuje metodologię, która - jeśli stosowana - sprawi, że
40 oprogramowanie sieciowe będzie prostsze w projektowaniu,
41 dokumentowaniu, pisaniu i ewoluowaniu.
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45
46 %build
47 %{__perl} Build.PL Makefile.PL \
48         installdirs=vendor \
49         destdir=$RPM_BUILD_ROOT
50 ./Build
51
52 %{?with_tests:./Build test}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 ./Build install
58
59 install -d $RPM_BUILD_ROOT%{perl_vendorlib}/CGI/%{pnam}/Plugin
60 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
61 cp -a Examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc README Changes
69 %{perl_vendorlib}/CGI/*.pm
70 %{perl_vendorlib}/CGI/%{pnam}
71 %{perl_vendorlib}/CGI/%{pnam}/Plugin
72 %{_examplesdir}/%{name}-%{version}
73 %{_mandir}/man3/*
This page took 0.056013 seconds and 4 git commands to generate.