]> git.pld-linux.org Git - packages/perl-CGI-Application-Plugin-TT.git/blob - perl-CGI-Application-Plugin-TT.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-CGI-Application-Plugin-TT.git] / perl-CGI-Application-Plugin-TT.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define pdir    CGI
6 %define pnam    Application-Plugin-TT
7 Summary:        CGI::Application::Plugin::TT - Add Template Toolkit support to CGI::Application
8 Name:           perl-CGI-Application-Plugin-TT
9 Version:        1.05
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/CGI/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  6e795c093a011cb701ab877deb0917a4
16 URL:            http://search.cpan.org/dist/CGI-Application-Plugin-TT/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl-CGI-Application >= 4.0
21 BuildRequires:  perl-Template-Toolkit >= 2.0
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 CGI::Application::Plugin::TT adds support for the popular Template
28 Toolkit engine to your CGI::Application modules by providing several
29 helper methods that allow you to process template files from within
30 your runmodes.
31
32 It compliments the support for HTML::Template that is built into
33 CGI::Application through the load_tmpl method. It also provides a few
34 extra features than just the ability to load a template.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Build.PL \
41         destdir=$RPM_BUILD_ROOT \
42         installdirs=vendor
43 ./Build
44
45 %{?with_tests:./Build test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 ./Build install
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes README
58 %{perl_vendorlib}/CGI/Application/Plugin/*.pm
59 #%{perl_vendorlib}/CGI/Application/Plugin/TT
60 %{_mandir}/man3/*
This page took 0.122923 seconds and 4 git commands to generate.