]> git.pld-linux.org Git - packages/perl-Benchmark-Timer.git/blob - perl-Benchmark-Timer.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Benchmark-Timer.git] / perl-Benchmark-Timer.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Benchmark
6 %define         pnam    Timer
7 Summary:        Benchmark::Timer - Perl code benchmarking tool
8 Summary(pl.UTF-8):      Benchmark::Timer - narzędzie do testowania wydajności kodu perlowego
9 Name:           perl-Benchmark-Timer
10 Version:        0.7102
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  d79a85ebdd458a34b5e979b636f5128b
17 URL:            http://search.cpan.org/dist/Benchmark-Timer/
18 BuildRequires:  perl-Statistics-TTest
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The Benchmark::Timer class allows you to time portions of code
26 conveniently, as well as benchmark code by allowing timings of
27 repeated trials. It is perfect for when you need more precise
28 information about the running time of portions of your code than the
29 Benchmark module will give you, but don't want to go all out and
30 profile your code.
31
32 %description -l pl.UTF-8
33 Klasa Benchmark::Timer pozwala wygodnie mierzyć czas wykonywania
34 fragmentów kodu, a także mierzyć wydajność kodu pozwalając na
35 mierzenie czasu w powtarzanych próbach. Jest to idealne jeśli
36 potrzebujemy bardziej precyzyjnej informacji o czasie działania
37 fragmentów kodu niż może dać moduł Benchmark, ale nie chcemy iść na
38 całość i profilować kodu.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46
47 %{__make}
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc CHANGES README
63 %dir %{perl_vendorlib}/Benchmark
64 %{perl_vendorlib}/Benchmark/Timer.pm
65 %{_mandir}/man3/*
This page took 0.082281 seconds and 4 git commands to generate.