]> git.pld-linux.org Git - packages/perl-BDB.git/blob - perl-BDB.spec
perl 5.38.0 rebuild
[packages/perl-BDB.git] / perl-BDB.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pnam    BDB
6 Summary:        BDB - Asynchronous Berkeley DB access
7 Summary(pl.UTF-8):      BDB - asynchroniczny dostęp do Berkeley DB
8 Name:           perl-BDB
9 Version:        1.92
10 Release:        6
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-authors/id/M/ML/MLEHMANN/%{pnam}-%{version}.tar.gz
15 # Source0-md5:  2be2ce3cf9457d7775a32f3006abc2c0
16 URL:            https://metacpan.org/dist/BDB
17 BuildRequires:  db-devel >= 4.3
18 BuildRequires:  perl-devel >= 1:5.8.8
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  rpmbuild(macros) >= 1.745
21 %if %{with tests}
22 BuildRequires:  perl-common-sense
23 %endif
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 BDB - Asynchronous Berkeley DB access.
28
29 %description -l pl.UTF-8
30 BDB - asynchroniczny dostęp do Berkeley DB.
31
32 %prep
33 %setup -q -n %{pnam}-%{version}
34
35 %build
36 %{__perl} Makefile.PL \
37         INSTALLDIRS=vendor
38 %{__make} \
39         CC="%{__cc}" \
40         OPTIMIZE="%{rpmcflags}"
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} pure_install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc Changes README
56 %{perl_vendorarch}/BDB.pm
57 %dir %{perl_vendorarch}/auto/BDB
58 %attr(755,root,root) %{perl_vendorarch}/auto/BDB/BDB.so
59 %{_mandir}/man3/BDB.3pm*
This page took 0.144778 seconds and 4 git commands to generate.