]> git.pld-linux.org Git - packages/perl-Audio-Musepack.git/blob - perl-Audio-Musepack.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Audio-Musepack.git] / perl-Audio-Musepack.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    Audio
6 %define pnam    Musepack
7 Summary:        An OO interface to Musepack file information and APE tag fields, implemented in pure Perl
8 Summary(pl.UTF-8):      Czysto perlowy interfejs obiektowy do informacji o plikach Musepack i znaczników APE
9 Name:           perl-Audio-Musepack
10 Version:        0.7
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Audio/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  a22b8426cae9f7c5006d5ee8fd780d5a
17 URL:            http://search.cpan.org/dist/Audio-Musepack/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-MP3-Info >= 1.20
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This module returns a hash containing basic information about a
28 Musepack file, as well as tag information contained in the Musepack
29 file's APE tags.
30
31 %description -l pl.UTF-8
32 Ten moduł zwraca hasza zawierającego podstawowe informacje o pliku
33 Musepack, a także informacje o znacznikach APE zawartych w pliku
34 Musepack.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes README
58 %{perl_vendorlib}/Audio/*.pm
59 %{_mandir}/man3/*
This page took 0.078168 seconds and 4 git commands to generate.