]> git.pld-linux.org Git - packages/perl-AppConfig.git/blob - perl-AppConfig.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-AppConfig.git] / perl-AppConfig.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    AppConfig
6 Summary:        AppConfig - Perl5 module for reading configuration files and parsing command line arguments
7 Summary(pl.UTF-8):      AppConfig - moduł Perla 5 do czytania plików konfiguracyjnych i analizy linii polecenia
8 Name:           perl-AppConfig
9 Version:        1.71
10 Release:        3
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/AppConfig/%{pdir}-%{version}.tar.gz
15 # Source0-md5:  7747d9241561ed5567d5e134b8648707
16 URL:            http://search.cpan.org/dist/AppConfig/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 Obsoletes:      perl-App-Config
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 AppConfig is a Perl5 module for managing application configuration
25 information. It maintains the state of any number of variables and
26 provides methods for parsing configuration files, command line
27 arguments and CGI script parameters.
28
29 %description -l pl.UTF-8
30 AppConfig jest modułem Perla 5 służącym do czytania informacji
31 konfiguracyjnych aplikacji. Zachowuje on stan dowolnej liczby
32 zmiennych i udostępnia metody do analizy plików konfiguracyjnych,
33 argumrntów linii polecenia i parametrów skryptów CGI.
34
35 %prep
36 %setup -q -n %{pdir}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make}
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes README
57 %{perl_vendorlib}/AppConfig
58 %{perl_vendorlib}/AppConfig.pm
59 %{_mandir}/man3/AppConfig*.3pm*
This page took 0.07065 seconds and 4 git commands to generate.