]> git.pld-linux.org Git - packages/perl-Apache-DBI.git/blob - perl-Apache-DBI.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Apache-DBI.git] / perl-Apache-DBI.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test"
4                         # fail while DBD::mysql is present
5 #
6 %define         pdir    Apache
7 %define         pnam    DBI
8 Summary:        Apache::DBI - initiate a persistent database connection
9 Summary(pl.UTF-8):      Apache::DBI - inicjowanie trwałego połączenia z bazą
10 Name:           perl-Apache-DBI
11 Version:        1.12
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  1bf6ca12b87de05bd53045325064636e
18 URL:            http://search.cpan.org/dist/Apache-DBI/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Apache::DBI and Apache::AuthDBI modules are supposed to be used with
26 the Apache server together with an embedded perl interpreter like
27 mod_perl. They provide support for basic authentication and
28 authorization as well as support for persistent database connections
29 via Perl's Database Independent Interface (DBI).
30
31 %description -l pl.UTF-8
32 Moduły Apache::DBI i Apache::AuthDBI są przeznaczone do używania
33 łącznie z serwerem Apache z wbudowanym interpreterem Perla takim jak
34 mod_perl. Zapewniają obsługę podstawowego uwierzytelnienia i
35 autoryzacji, a także obsługę ciągłych połączeń z bazą danych poprzez
36 ogólny interfejs dostępu do baz danych Perla (DBI).
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc README Changes
60 %{perl_vendorlib}/%{pdir}/*.pm
61 %{_mandir}/man3/*
This page took 0.058655 seconds and 4 git commands to generate.