]> git.pld-linux.org Git - packages/openssl.git/blob - openssl.spec
fc77b6fb8cfde213f732c33f59b6af0896b551d8
[packages/openssl.git] / openssl.spec
1 # TODO
2 # - consider dropping last optflags.patch hunk and return to SOMAJOR (.so.1) sonames
3 # - find a way to simplify (drop) openssl-optflags.patch, it's pain to update here in pld
4 # - make with sslv2 bcond work (or drop) after 1.0.2g
5 #
6 # Conditional build:
7 %bcond_without  tests   # don't perform "make tests"
8 %bcond_without  zlib    # zlib: note - enables CVE-2012-4929 vulnerability
9 %bcond_without  sslv2   # SSLv2: note - many flaws http://en.wikipedia.org/wiki/Transport_Layer_Security#SSL_2.0
10 %bcond_without  sslv3   # SSLv3: note - enables  CVE-2014-3566 vulnerability
11 %bcond_with     purify  # Compile openssl with "-DPURIFY", useful when one wants to
12                         # use valgrind debugger against openssl-linked programs
13 %bcond_with     snap    # use GitHub snapshot to build branch release
14
15 %include        /usr/lib/rpm/macros.perl
16 Summary:        OpenSSL Toolkit libraries for the "Secure Sockets Layer" (SSL v2/v3)
17 Summary(de.UTF-8):      Secure Sockets Layer (SSL)-Kommunikationslibrary
18 Summary(es.UTF-8):      Biblioteca C que suministra algoritmos y protocolos criptográficos
19 Summary(fr.UTF-8):      Utilitaires de communication SSL (Secure Sockets Layer)
20 Summary(pl.UTF-8):      Biblioteki OpenSSL (SSL v2/v3)
21 Summary(pt_BR.UTF-8):   Uma biblioteca C que fornece vários algoritmos e protocolos criptográficos
22 Summary(ru.UTF-8):      Библиотеки и утилиты для соединений через Secure Sockets Layer
23 Summary(uk.UTF-8):      Бібліотеки та утиліти для з'єднань через Secure Sockets Layer
24 Name:           openssl
25 # 1.0.2 will be LTS release
26 # Version 1.0.2 will be supported until 2019-12-31.
27 # https://www.openssl.org/about/releasestrat.html
28 Version:        1.0.2g
29 Release:        6
30 License:        Apache-like
31 Group:          Libraries
32 %if %{without snap}
33 Source0:        ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
34 # Source0-md5:  f3c710c045cdee5fd114feb69feba7aa
35 %else
36 Source1:        https://github.com/openssl/openssl/archive/OpenSSL_1_0_2-stable/%{name}-%{version}-dev.tar.gz
37 %endif
38 Source2:        %{name}.1.pl
39 Source3:        %{name}-ssl-certificate.sh
40 Source4:        %{name}-c_rehash.sh
41 Patch0:         %{name}-alpha-ccc.patch
42 Patch1:         %{name}-optflags.patch
43 Patch2:         %{name}-include.patch
44 Patch3:         %{name}-man-namespace.patch
45 Patch4:         %{name}-asflag.patch
46 Patch5:         %{name}-ca-certificates.patch
47 Patch6:         %{name}-ldflags.patch
48 Patch7:         %{name}-find.patch
49 Patch8:         pic.patch
50 Patch10:        %{name}_fix_for_x32.patch
51 URL:            http://www.openssl.org/
52 BuildRequires:  bc
53 BuildRequires:  perl-devel >= 1:5.6.1
54 BuildRequires:  rpm-perlprov >= 4.1-13
55 BuildRequires:  rpmbuild(macros) >= 1.213
56 BuildRequires:  sed >= 4.0
57 Requires:       ca-certificates >= 20120623-1.1
58 Requires:       rpm-whiteout >= 1.7
59 Obsoletes:      SSLeay
60 Obsoletes:      SSLeay-devel
61 Obsoletes:      SSLeay-perl
62 Obsoletes:      libopenssl0
63 %if "%{pld_release}" == "ac"
64 Conflicts:      neon < 0.26.3-3
65 Conflicts:      ntpd < 4.2.4p8-10
66 Conflicts:      openssh-clients < 2:5.8p1-9
67 Conflicts:      openssh-server < 2:5.8p1-9
68 %else
69 Conflicts:      QtNetwork < 4.8.7-8
70 Conflicts:      apache-mod_ssl < 1:2.2.31-4
71 Conflicts:      curl-libs < 7.47.1-2
72 Conflicts:      neon < 0.29.6-8
73 Conflicts:      openssh-clients < 2:6.2p2-3
74 Conflicts:      openssh-server < 2:6.2p2-3
75 Conflicts:      php52-common < 4:5.2.17-20130717.17
76 Conflicts:      php53-common < 4:5.3.29-27
77 Conflicts:      php54-common < 4:5.4.45-5
78 Conflicts:      php55-common < 4:5.5.32-2
79 Conflicts:      php56-common < 4:5.6.18-3
80 Conflicts:      python-modules < 1:2.7.10-8
81 Conflicts:      python3-modules < 1:3.5.0-9
82 Conflicts:      ruby-modules < 1:2.0.0.648-2
83 %endif
84 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85
86 %description
87 The OpenSSL Project is a collaborative effort to develop a robust,
88 commercial-grade, full-featured, and Open Source toolkit implementing
89 the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS
90 v1) protocols with full-strength cryptography world-wide. The project
91 is managed by a worldwide community of volunteers that use the
92 Internet to communicate, plan, and develop the OpenSSL tookit and its
93 related documentation.
94
95 OpenSSL is based on the excellent SSLeay library developed by Eric A.
96 Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
97 Apache-style licence, which basically means that you are free to get
98 and use it for commercial and non-commercial purposes subject to some
99 simple license conditions.
100
101 This package contains shared libraries only, install openssl-tools if
102 you want to use openssl cmdline tool.
103
104 %description -l de.UTF-8
105 Openssl enthält das OpenSSL Zertifikatsmanagementtool und shared
106 libraries, die verschiedene Verschlüsselungs- und
107 Entschlüsselungsalgorithmen und -protokolle, wie DES, RC4, RSA und SSL
108 zur Verfügung stellen.
109
110 %description -l es.UTF-8
111 Biblioteca C que suministra algoritmos y protocolos criptográficos.
112
113 %description -l fr.UTF-8
114 OpenSSL est un outiil de gestion des certificats et les librairies
115 partagees qui fournit plusieurs protocoles et algorithmes de
116 codage/decodage, incluant DES, RC4, RSA et SSL.
117
118 %description -l pl.UTF-8
119 Implementacja protokołów kryptograficznych Secure Socket Layer (SSL)
120 v2/v3 oraz Transport Layer Security (TLS v1).
121
122 %description -l pt_BR.UTF-8
123 Uma biblioteca C que fornece vários algoritmos e protocolos
124 criptográficos, incluindo DES, RC4, RSA e SSL. Inclui bibliotecas
125 compartilhadas e utilitários.
126
127 %description -l ru.UTF-8
128 Программа openssl для работы с сертификатами и разделяемые библиотеки,
129 которые реализуют множетсво криптографических алгоритмов, включая DES,
130 RC4, RSA и SSL.
131
132 %description -l uk.UTF-8
133 Програма openssl для роботи з сертифікатами та бібліотеки спільного
134 користування, що реалізують велику кількість криптографічних
135 алгоритмів, включаючи DES, RC4, RSA та SSL.
136
137 %package engines
138 Summary:        OpenSSL optional crypto engines
139 Summary(pl.UTF-8):      Opcjonalne silniki kryptograficzne dla OpenSSL-a
140 Group:          Libraries
141 Requires:       %{name} = %{version}-%{release}
142
143 %description engines
144 With OpenSSL 0.9.6, a new component was added to support alternative
145 cryptography implementations, most commonly for interfacing with
146 external crypto devices (eg. accelerator cards). This component is
147 called ENGINE.
148
149 There are currently built-in ENGINE implementations for the following
150 crypto devices:
151
152 - CryptoSwift
153 - Compaq Atalla
154 - nCipher CHIL
155 - Nuron
156 - Broadcom uBSec
157
158 In addition, dynamic binding to external ENGINE implementations is now
159 provided by a special ENGINE called "dynamic".
160
161 %description engines -l pl.UTF-8
162 Począwszy od OpenSSL-a 0.9.6 został dodany nowy komponent, mający
163 wspierać alternatywne implementacje kryptografii, przeważnie
164 współpracujące z zewnętrznymi urządzeniami kryptograficznymi (np.
165 kartami akceleratorów). Komponent ten jest nazywany SILNIKIEM (ang.
166 ENGINE).
167
168 Obecnie istnieją wbudowane implementacje silników dla następujących
169 urządzeń kryptograficznych:
170 - CryptoSwift
171 - Compaq Atalla
172 - nCipher CHIL
173 - Nuron
174 - Broadcom uBSec
175
176 Ponadto zapewnione jest dynamiczne wiązanie dla zewnętrznych
177 implementacji silników poprzez specjalny silnik o nazwie "dynamic".
178
179 %package tools
180 Summary:        OpenSSL command line tool and utilities
181 Summary(pl.UTF-8):      Zestaw narzędzi i skryptów
182 Group:          Applications/Communications
183 Requires:       %{name} = %{version}-%{release}
184 Requires:       which
185
186 %description tools
187 The OpenSSL Toolkit cmdline tool openssl and utility scripts.
188
189 %description tools -l pl.UTF-8
190 Zestaw narzędzi i skryptów wywoływanych z linii poleceń.
191
192 %package tools-perl
193 Summary:        OpenSSL utilities written in Perl
194 Summary(pl.UTF-8):      Narzędzia OpenSSL napisane w perlu
195 Group:          Applications/Communications
196 Requires:       %{name} = %{version}-%{release}
197
198 %description tools-perl
199 OpenSSL Toolkit tools written in Perl.
200
201 %description tools-perl -l pl.UTF-8
202 Narzędzia OpenSSL napisane w perlu.
203
204 %package devel
205 Summary:        Development part of OpenSSL Toolkit libraries
206 Summary(de.UTF-8):      Secure Sockets Layer Kommunikationslibrary: statische libraries+header
207 Summary(es.UTF-8):      Bibliotecas y archivos de inclusión para desarrollo OpenSSL
208 Summary(fr.UTF-8):      Librairies statiques, headers et utilitaires pour communication SSL
209 Summary(pl.UTF-8):      Część bibiloteki OpenSSL przeznaczona dla programistów
210 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para desenvolvimento OpenSSL
211 Summary(ru.UTF-8):      Библиотеки, хедеры и утилиты для Secure Sockets Layer
212 Summary(uk.UTF-8):      Бібліотеки, хедери та утиліти для Secure Sockets Layer
213 Group:          Development/Libraries
214 Requires:       %{name} = %{version}-%{release}
215 Obsoletes:      libopenssl0-devel
216
217 %description devel
218 Development part of OpenSSL library.
219
220 %description devel -l es.UTF-8
221 Bibliotecas y archivos de inclusión para desarrollo OpenSSL
222
223 %description devel -l pl.UTF-8
224 Część biblioteki OpenSSL przeznaczona dla programistów.
225
226 %description devel -l pt_BR.UTF-8
227 Uma biblioteca C que fornece vários algoritmos e protocolos
228 criptográficos, incluindo DES, RC4, RSA e SSL. Inclui bibliotecas e
229 arquivos de inclusão para desenvolvimento.
230
231 %description devel -l ru.UTF-8
232 Программа openssl для работы с сертификатами и разделяемые библиотеки,
233 которые реализуют множетсво криптографических алгоритмов, включая DES,
234 RC4, RSA и SSL. Включает библиотеки и хедеры для разработки приложений
235 с использованием SSL.
236
237 %description devel -l uk.UTF-8
238 Програма openssl для роботи з сертифікатами та бібліотеки спільного
239 користування, що реалізують велику кількість криптографічних
240 алгоритмів, включаючи DES, RC4, RSA та SSL. Містить бібліотеки та
241 хедери для розробки програм з використанням SSL.
242
243 %package static
244 Summary:        Static OpenSSL libraries
245 Summary(pl.UTF-8):      Statyczne wersje bibliotek z OpenSSL
246 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com openssl
247 Summary(ru.UTF-8):      Статические библиотеки разработчика для OpenSSL
248 Summary(uk.UTF-8):      Статичні бібліотеки програміста для OpenSSL
249 Group:          Development/Libraries
250 Requires:       %{name}-devel = %{version}-%{release}
251
252 %description static
253 Static OpenSSL Toolkit libraries.
254
255 %description static -l pl.UTF-8
256 Statyczne wersje bibliotek z OpenSSL.
257
258 %description static -l pt_BR.UTF-8
259 Bibliotecas estáticas para desenvolvimento com openssl.
260
261 %description static -l ru.UTF-8
262 Программа openssl для работы с сертификатами и разделяемые библиотеки,
263 которые реализуют множетсво криптографических алгоритмов, включая DES,
264 RC4, RSA и SSL. Включает статические библиотеки для разработки
265 приложений с использованием OpenSSL.
266
267 %description static -l uk.UTF-8
268 Програма openssl для роботи з сертифікатами та бібліотеки спільного
269 користування, що реалізують велику кількість криптографічних
270 алгоритмів, включаючи DES, RC4, RSA та SSL. Містить статичні
271 бібліотеки для розробки програм з використанням SSL.
272
273 %prep
274 %if %{with snap}
275 %setup -qcT -a1
276 mv %{name}-OpenSSL_1_0_2-stable/* .
277 %else
278 %setup -q
279 %endif
280 %patch0 -p1
281 %patch1 -p1
282 %patch2 -p1
283 %patch3 -p1
284 %patch4 -p1
285 %patch5 -p1
286 %patch6 -p1
287 %patch7 -p1
288 %patch8 -p1
289 %ifarch x32
290 %patch10 -p1
291 %endif
292
293 sed -i -e 's|\$prefix/\$libdir/engines|/%{_lib}/engines|g' Configure
294
295 %build
296 touch Makefile.*
297
298 %{__perl} util/perlpath.pl %{__perl}
299
300 OPTFLAGS="%{rpmcflags} %{rpmcppflags} %{?with_purify:-DPURIFY}" \
301 PERL="%{__perl}" \
302 %{__perl} ./Configure \
303         --openssldir=%{_sysconfdir}/%{name} \
304         --libdir=%{_lib} \
305         shared \
306         threads \
307         %{!?with_sslv2:no-ssl2} \
308         %{!?with_sslv3:no-ssl3} \
309         %{!?with_zlib:no-}zlib \
310         enable-camelia \
311         enable-cms \
312         enable-idea \
313         enable-md2 \
314         enable-mdc2 \
315         enable-rc5 \
316         enable-rfc3779 \
317         enable-seed \
318         enable-tlsext \
319 %ifarch %{x8664}
320         enable-ec_nistp_64_gcc_128 \
321 %endif
322 %ifarch %{ix86}
323 %ifarch i386
324         386 linux-elf
325 # ^- allow running on 80386 (default code uses bswapl available on i486+)
326 %else
327         linux-elf
328 %endif
329 %endif
330 %ifarch alpha
331         linux-alpha+bwx-gcc
332 %endif
333 %ifarch %{x8664}
334         linux-x86_64
335 %endif
336 %ifarch x32
337         linux-x32
338 %endif
339 %ifarch ia64
340         linux-ia64
341 %endif
342 %ifarch ppc
343         linux-ppc
344 %endif
345 %ifarch ppc64
346         linux-ppc64
347 %endif
348 %ifarch sparc
349         linux-sparcv8
350 %endif
351 %ifarch sparcv9
352         linux-sparcv9
353 %endif
354 %ifarch sparc64
355         linux64-sparcv9
356 %endif
357 %ifarch armv4 armv5 armv5t armv5te armv5tel
358         linux-armv4
359 %endif
360
361 v=$(awk -F= '/^VERSION/{print $2}' Makefile)
362 test "$v" = %{version}%{?with_snap:-dev}
363
364 %{__make} -j1 all rehash %{?with_tests:tests} \
365         CC="%{__cc}" \
366         ASFLAG='$(CFLAG) -Wa,--noexecstack' \
367         INSTALLTOP=%{_prefix}
368
369 # Rename POD sources of man pages. "openssl_" prefix is added to each
370 # manpage to avoid potential conflicts with other packages.
371
372 for dir in doc/{apps,ssl,crypto}; do
373         cd $dir || exit 1;
374         %{__perl} -pi -e 's/(\W)((?<!openssl_)\w+)(\(\d\))/$1openssl_$2$3/g; s/openssl_openssl/openssl/g;' *.pod;
375
376         for pod in !(openssl*).pod; do
377                 mv -f $pod openssl_$pod;
378         done
379         cd ../..
380 done
381
382 %install
383 rm -rf $RPM_BUILD_ROOT
384 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_libdir}/%{name}} \
385         $RPM_BUILD_ROOT{%{_mandir}/{pl/man1,man{1,3,5,7}},%{_datadir}/ssl} \
386         $RPM_BUILD_ROOT/%{_lib}/engines \
387         $RPM_BUILD_ROOT%{_pkgconfigdir}
388
389 %{__make} -j1 install \
390         INSTALLTOP=%{_prefix} \
391         INSTALL_PREFIX=$RPM_BUILD_ROOT \
392         MANDIR=%{_mandir}
393
394 mv -f $RPM_BUILD_ROOT%{_libdir}/engines/* $RPM_BUILD_ROOT/%{_lib}/engines
395 mv -f $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.* $RPM_BUILD_ROOT/%{_lib}
396 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libcrypto.*.*) $RPM_BUILD_ROOT%{_libdir}/libcrypto.so
397 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libssl.*.*) $RPM_BUILD_ROOT%{_libdir}/libssl.so
398
399 mv -f $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc/* $RPM_BUILD_ROOT%{_libdir}/%{name}
400 rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc
401
402 # not installed as individual utilities (see openssl dgst instead)
403 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{dss1,md2,md4,md5,mdc2,ripemd160,sha,sha1,sha224,sha256,sha384,sha512}.1
404
405 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/pl/man1/openssl.1
406 install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/ssl-certificate
407 install -p %{SOURCE4} $RPM_BUILD_ROOT%{_bindir}/c_rehash.sh
408
409 %clean
410 rm -rf $RPM_BUILD_ROOT
411
412 %post   -p /sbin/ldconfig
413 %postun -p /sbin/ldconfig
414
415 %triggerpostun -- %{name}-tools < 1.0.0-5
416 # the hashing format has changed in 1.0.0
417 [ ! -x %{_sbindir}/update-ca-certificates ] || %{_sbindir}/update-ca-certificates --fresh || :
418
419 %triggerpostun -- %{name} < 0.9.8i-2
420 # don't do anything on --downgrade
421 if [ $1 -le 1 ]; then
422         exit 0
423 fi
424 if [ -d /var/lib/openssl/certs ] ; then
425         mv /var/lib/openssl/certs/* %{_sysconfdir}/%{name}/certs 2>/dev/null || :
426 fi
427 if [ -d /var/lib/openssl/private ] ; then
428         mv /var/lib/openssl/private/* %{_sysconfdir}/%{name}/private 2>/dev/null || :
429 fi
430 if [ -d /var/lib/openssl ] ; then
431         for f in /var/lib/openssl/* ; do
432                 [ -f "$f" ] && mv "$f" %{_sysconfdir}/%{name} 2>/dev/null || :
433         done
434         rmdir /var/lib/openssl/* 2>/dev/null || :
435         rmdir /var/lib/openssl 2>/dev/null || :
436 fi
437
438 %files
439 %defattr(644,root,root,755)
440 %doc CHANGES CHANGES.SSLeay LICENSE NEWS README doc/*.txt
441 %attr(755,root,root) /%{_lib}/libcrypto.so.*.*.*
442 %attr(755,root,root) /%{_lib}/libssl.so.*.*.*
443 %dir %{_sysconfdir}/%{name}
444 %dir %{_sysconfdir}/%{name}/certs
445 %dir %attr(700,root,root) %{_sysconfdir}/%{name}/private
446 %dir %{_datadir}/ssl
447
448 %files engines
449 %defattr(644,root,root,755)
450 %dir /%{_lib}/engines
451 %attr(755,root,root) /%{_lib}/engines/*.so
452
453 %files tools
454 %defattr(644,root,root,755)
455 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/openssl.cnf
456 %attr(755,root,root) %{_bindir}/c_rehash.sh
457 %attr(755,root,root) %{_bindir}/openssl
458 %attr(754,root,root) %{_bindir}/ssl-certificate
459
460 %dir %{_libdir}/%{name}
461 %attr(755,root,root) %{_libdir}/%{name}/CA.sh
462 %attr(755,root,root) %{_libdir}/%{name}/c_hash
463 %attr(755,root,root) %{_libdir}/%{name}/c_info
464 %attr(755,root,root) %{_libdir}/%{name}/c_issuer
465 %attr(755,root,root) %{_libdir}/%{name}/c_name
466
467 %{_mandir}/man1/openssl.1*
468 %{_mandir}/man1/openssl_asn1parse.1*
469 %{_mandir}/man1/openssl_ca.1*
470 %{_mandir}/man1/openssl_ciphers.1*
471 %{_mandir}/man1/openssl_cms.1*
472 %{_mandir}/man1/openssl_crl.1*
473 %{_mandir}/man1/openssl_crl2pkcs7.1*
474 %{_mandir}/man1/openssl_dgst.1*
475 %{_mandir}/man1/openssl_dhparam.1*
476 %{_mandir}/man1/openssl_dsa.1*
477 %{_mandir}/man1/openssl_dsaparam.1*
478 %{_mandir}/man1/openssl_ec.1*
479 %{_mandir}/man1/openssl_ecparam.1*
480 %{_mandir}/man1/openssl_enc.1*
481 %{_mandir}/man1/openssl_errstr.1*
482 %{_mandir}/man1/openssl_gendsa.1*
483 %{_mandir}/man1/openssl_genpkey.1*
484 %{_mandir}/man1/openssl_genrsa.1*
485 %{_mandir}/man1/openssl_nseq.1*
486 %{_mandir}/man1/openssl_ocsp.1*
487 %{_mandir}/man1/openssl_passwd.1*
488 %{_mandir}/man1/openssl_pkcs12.1*
489 %{_mandir}/man1/openssl_pkcs7.1*
490 %{_mandir}/man1/openssl_pkcs8.1*
491 %{_mandir}/man1/openssl_pkey.1*
492 %{_mandir}/man1/openssl_pkeyparam.1*
493 %{_mandir}/man1/openssl_pkeyutl.1*
494 %{_mandir}/man1/openssl_rand.1*
495 %{_mandir}/man1/openssl_req.1*
496 %{_mandir}/man1/openssl_rsa.1*
497 %{_mandir}/man1/openssl_rsautl.1*
498 %{_mandir}/man1/openssl_s_client.1*
499 %{_mandir}/man1/openssl_s_server.1*
500 %{_mandir}/man1/openssl_s_time.1*
501 %{_mandir}/man1/openssl_sess_id.1*
502 %{_mandir}/man1/openssl_smime.1*
503 %{_mandir}/man1/openssl_speed.1*
504 %{_mandir}/man1/openssl_spkac.1*
505 %{_mandir}/man1/openssl_ts.1*
506 %{_mandir}/man1/openssl_tsget.1*
507 %{_mandir}/man1/openssl_verify.1*
508 %{_mandir}/man1/openssl_version.1*
509 %{_mandir}/man1/openssl_x509.1*
510 %{_mandir}/man5/openssl_config.5*
511 %{_mandir}/man5/openssl_x509v3_config.5*
512 %lang(pl) %{_mandir}/pl/man1/openssl.1*
513
514 %files tools-perl
515 %defattr(644,root,root,755)
516 %attr(755,root,root) %{_bindir}/c_rehash
517 %attr(755,root,root) %{_libdir}/%{name}/CA.pl
518 %attr(755,root,root) %{_libdir}/%{name}/tsget
519 %{_mandir}/man1/openssl_CA.pl.1*
520 %{_mandir}/man1/openssl_c_rehash.1*
521
522 %files devel
523 %defattr(644,root,root,755)
524 %attr(755,root,root) %{_libdir}/libcrypto.so
525 %attr(755,root,root) %{_libdir}/libssl.so
526 %{_includedir}/%{name}
527 %{_pkgconfigdir}/libcrypto.pc
528 %{_pkgconfigdir}/libssl.pc
529 %{_pkgconfigdir}/openssl.pc
530 %{_mandir}/man3/openssl*.3*
531 %{_mandir}/man7/openssl_des_modes.7*
532
533 %files static
534 %defattr(644,root,root,755)
535 %{_libdir}/libcrypto.a
536 %{_libdir}/libssl.a
This page took 0.082747 seconds and 2 git commands to generate.