]> git.pld-linux.org Git - packages/opencl-clang.git/commitdiff
up to 10.0.0 auto/th/opencl-clang-10.0.0-1
authorJan Palus <atler@pld-linux.org>
Fri, 10 Apr 2020 14:33:54 +0000 (16:33 +0200)
committerJan Palus <atler@pld-linux.org>
Fri, 10 Apr 2020 14:33:54 +0000 (16:33 +0200)
- patch fixing https://bugs.llvm.org/show_bug.cgi?id=44870

llvm10.patch [new file with mode: 0644]
opencl-clang.spec

diff --git a/llvm10.patch b/llvm10.patch
new file mode 100644 (file)
index 0000000..5a4c3df
--- /dev/null
@@ -0,0 +1,13 @@
+--- opencl-clang-10.0.0/CMakeLists.txt.orig    2020-04-10 16:29:26.493507026 +0200
++++ opencl-clang-10.0.0/CMakeLists.txt 2020-04-10 16:32:55.252632824 +0200
+@@ -218,6 +218,10 @@
+ set(LLVM_REQUIRES_EH ON)
++if(LLVM_PACKAGE_VERSION VERSION_GREATER_EQUAL 10.0.0 AND Polly IN_LIST LLVM_AVAILABLE_LIBS)
++  list(APPEND ADDITIONAL_LIBS Polly)
++endif()
++
+ add_llvm_library(${TARGET_NAME} SHARED
+   ${TARGET_INCLUDE_FILES}
+   ${TARGET_SOURCE_FILES}
index ac0bffa0b193b7ea58418fda360862618b368ce5..ff016496be3280f79007153818d585a961c9fe9e 100644 (file)
@@ -1,17 +1,18 @@
 
 # requires the OpenCL patches
-%define llvm_version 9.0.0
+%define llvm_version 10.0.0
 
-%define spirv_llvm_translator_version 9.0.0
+%define spirv_llvm_translator_version 10.0.0
 
 Summary:       Intel Graphics Compute Runtime for OpenCL
 Name:          opencl-clang
-Version:       9.0.0
-Release:       2
+Version:       10.0.0
+Release:       1
 License:       University of Illinois/NCSA Open Source License
 Group:         Libraries
 Source0:       https://github.com/intel/opencl-clang/archive/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: ca856bc6ec05fcf3a7d8374d97904b28
+# Source0-md5: a28bc82341f0ef4dbf749d2ee5e0a907
+Patch0:                llvm10.patch
 URL:           https://01.org/compute-runtime
 BuildRequires: SPIRV-LLVM-Translator-devel >= %{spirv_llvm_translator_version}
 BuildRequires: clang >= %{llvm_rpm_version}
@@ -41,6 +42,7 @@ Pliki nagłówkowe biblioteki %{name}.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 install -d build
@@ -62,8 +64,8 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
-mv $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.9 $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.%{llvm_version}
-ln -s libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.9
+mv $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.10 $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.%{llvm_version}
+ln -s libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.10
 ln -sf libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so
 
 %post  -p /sbin/ldconfig
@@ -76,7 +78,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc README.md
 %attr(755,root,root) %{_libdir}/libopencl-clang.so.%{llvm_version}
-%ghost %attr(755,root,root) %{_libdir}/libopencl-clang.so.9
+%ghost %attr(755,root,root) %{_libdir}/libopencl-clang.so.10
 
 %files devel
 %defattr(644,root,root,755)
This page took 0.128554 seconds and 4 git commands to generate.