]> git.pld-linux.org Git - packages/opencl-clang.git/commitdiff
up to 9.0.0 auto/th/opencl-clang-9.0.0-1
authorJan Palus <atler@pld-linux.org>
Thu, 5 Dec 2019 13:40:30 +0000 (14:40 +0100)
committerJan Palus <atler@pld-linux.org>
Thu, 5 Dec 2019 13:40:30 +0000 (14:40 +0100)
align-with-modified-llvm-writespirv-api.patch [deleted file]
opencl-clang.spec

diff --git a/align-with-modified-llvm-writespirv-api.patch b/align-with-modified-llvm-writespirv-api.patch
deleted file mode 100644 (file)
index a0d6f98..0000000
+++ /dev/null
@@ -1,71 +0,0 @@
-From 94af090661d7c953c516c97a25ed053c744a0737 Mon Sep 17 00:00:00 2001
-From: Alexey Sotkin <alexey.sotkin@intel.com>
-Date: Mon, 18 Feb 2019 18:19:13 +0300
-Subject: [PATCH] Align with modified llvm::writeSpirv API
-
----
- common_clang.cpp | 29 +++++++++++++++++++++++++----
- 1 file changed, 25 insertions(+), 4 deletions(-)
-
-diff --git a/common_clang.cpp b/common_clang.cpp
-index eff1064..ee1ec9b 100644
---- a/common_clang.cpp
-+++ b/common_clang.cpp
-@@ -63,17 +63,18 @@ Copyright (c) Intel Corporation (2009-2017).
- #define CL_OUT_OF_HOST_MEMORY -6
- #include "assert.h"
--#include <list>
-+#include <algorithm>
- #include <iosfwd>
--#include <sstream>
- #include <iterator>
--#include <algorithm>
-+#include <list>
-+#include <streambuf>
- #ifdef _WIN32
- #include <ctype.h>
- #endif
- #if defined _DEBUG
- #include <cstdlib>
-+#include <sstream>
- #include <fstream>
- #include <thread>
- #endif
-@@ -164,6 +165,25 @@ static void PrintCompileOptions(const char *pszOptions, const char *pszOptionsEx
- #endif
- }
-+class SmallVectorBuffer : public std::streambuf
-+{
-+  // All memory management is delegated to llvm::SmallVectorImpl
-+  llvm::SmallVectorImpl<char> &OS;
-+
-+  // Since we don't touch any pointer in streambuf(pbase, pptr, epptr) this is
-+  // the only method we need to override.
-+  virtual std::streamsize xsputn(const char *s, std::streamsize  n) override {
-+    OS.append(s, s + n);
-+    return n;
-+  }
-+
-+public:
-+  SmallVectorBuffer() = delete;
-+  SmallVectorBuffer(const SmallVectorBuffer&) = delete;
-+  SmallVectorBuffer &operator=(const SmallVectorBuffer&) = delete;
-+  SmallVectorBuffer(llvm::SmallVectorImpl<char> &O) : OS(O) {}
-+};
-+
- extern "C" CC_DLL_EXPORT int
- Compile(const char *pszProgramSource, const char **pInputHeaders,
-         unsigned int uiNumInputHeaders, const char **pInputHeadersNames,
-@@ -300,7 +320,8 @@ Compile(const char *pszProgramSource, const char **pInputHeaders,
-         return CL_COMPILE_PROGRAM_FAILURE;
-       }
-       pResult->getIRBufferRef().clear();
--      llvm::raw_svector_ostream OS(pResult->getIRBufferRef());
-+      SmallVectorBuffer StreamBuf(pResult->getIRBufferRef());
-+      std::ostream OS(&StreamBuf);
-       std::string Err;
-       success = llvm::writeSpirv(M.get(), OS, Err);
-       err_ostream << Err.c_str();
index 6fbee66a6e30a6672cf5abc8c452352398b746f1..284d500a8a5ad376e27307a301f9799845ee690c 100644 (file)
@@ -1,18 +1,17 @@
 
 # requires the OpenCL patches
 
 # requires the OpenCL patches
-%define llvm_version 8.0.1
+%define llvm_version 9.0.0
 
 
-%define spirv_llvm_translator_version 8.0.1
+%define spirv_llvm_translator_version 9.0.0
 
 Summary:       Intel Graphics Compute Runtime for OpenCL
 Name:          opencl-clang
 
 Summary:       Intel Graphics Compute Runtime for OpenCL
 Name:          opencl-clang
-Version:       8.0.1
-Release:       2
+Version:       9.0.0
+Release:       1
 License:       University of Illinois/NCSA Open Source License
 Group:         Libraries
 Source0:       https://github.com/intel/opencl-clang/archive/v%{version}/%{name}-%{version}.tar.gz
 License:       University of Illinois/NCSA Open Source License
 Group:         Libraries
 Source0:       https://github.com/intel/opencl-clang/archive/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: cb6b746c837a6cac6c8906911b2ea9de
-Patch0:                align-with-modified-llvm-writespirv-api.patch
+# Source0-md5: ca856bc6ec05fcf3a7d8374d97904b28
 URL:           https://01.org/compute-runtime
 BuildRequires: SPIRV-LLVM-Translator-devel >= %{spirv_llvm_translator_version}
 BuildRequires: clang >= %{llvm_rpm_version}
 URL:           https://01.org/compute-runtime
 BuildRequires: SPIRV-LLVM-Translator-devel >= %{spirv_llvm_translator_version}
 BuildRequires: clang >= %{llvm_rpm_version}
@@ -42,7 +41,6 @@ Pliki nagłówkowe biblioteki %{name}.
 
 %prep
 %setup -q
 
 %prep
 %setup -q
-%patch0 -p1
 
 %build
 install -d build
 
 %build
 install -d build
@@ -64,8 +62,8 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
 %{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
-mv $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.8 $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.%{llvm_version}
-ln -s libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.8
+mv $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.9 $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.%{llvm_version}
+ln -s libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.9
 ln -sf libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so
 
 %post  -p /sbin/ldconfig
 ln -sf libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so
 
 %post  -p /sbin/ldconfig
@@ -78,7 +76,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc README.md
 %attr(755,root,root) %{_libdir}/libopencl-clang.so.%{llvm_version}
 %defattr(644,root,root,755)
 %doc README.md
 %attr(755,root,root) %{_libdir}/libopencl-clang.so.%{llvm_version}
-%ghost %attr(755,root,root) %{_libdir}/libopencl-clang.so.8
+%ghost %attr(755,root,root) %{_libdir}/libopencl-clang.so.9
 
 %files devel
 %defattr(644,root,root,755)
 
 %files devel
 %defattr(644,root,root,755)
This page took 0.145256 seconds and 4 git commands to generate.