]> git.pld-linux.org Git - packages/opencl-clang.git/commitdiff
updated to snap from LLVM 12 branch (until proper release is made) auto/th/opencl-clang-12.0.0-0.20210525.1
authorJan Palus <atler@pld-linux.org>
Tue, 25 May 2021 10:36:44 +0000 (12:36 +0200)
committerJan Palus <atler@pld-linux.org>
Tue, 25 May 2021 10:39:18 +0000 (12:39 +0200)
opencl-clang.spec

index 95e9040229a83d0aa4553e83e341a44fb2f3b166..46ff2f789d82891ab5c23aca1e4a7dfb0e2ef0f0 100644 (file)
@@ -1,17 +1,20 @@
 
 # requires the OpenCL patches
-%define llvm_version 11.0.0
+%define llvm_version 12.0.0
 
-%define spirv_llvm_translator_version 11.0.0
+%define spirv_llvm_translator_version 12.0.0
+
+%define        gitref  1d1829d930d31309c43512fc17ece51dd314ebde
+%define        snap    20210525
 
 Summary:       Intel Graphics Compute Runtime for OpenCL
 Name:          opencl-clang
-Version:       11.0.0
-Release:       4
+Version:       12.0.0
+Release:       0.%{snap}.1
 License:       University of Illinois/NCSA Open Source License
 Group:         Libraries
-Source0:       https://github.com/intel/opencl-clang/archive/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 31e0ca207e06d6bb1a49661cafd8a3ea
+Source0:       https://github.com/intel/opencl-clang/archive/%{gitref}/%{name}-%{snap}.tar.gz
+# Source0-md5: aa6983d5d43d2d92727837a8c1669c9f
 URL:           https://01.org/compute-runtime
 BuildRequires: SPIRV-LLVM-Translator-devel >= %{spirv_llvm_translator_version}
 BuildRequires: clang >= %{llvm_rpm_version}
@@ -40,7 +43,7 @@ Header files for %{name} library.
 Pliki nagłówkowe biblioteki %{name}.
 
 %prep
-%setup -q
+%setup -q -n %{name}-%{gitref}
 
 %build
 install -d build
@@ -62,8 +65,8 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
-mv $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.11 $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.%{llvm_version}
-ln -s libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.11
+mv $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.12 $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.%{llvm_version}
+ln -s libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.12
 ln -sf libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so
 
 %post  -p /sbin/ldconfig
@@ -76,7 +79,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc README.md
 %attr(755,root,root) %{_libdir}/libopencl-clang.so.%{llvm_version}
-%ghost %attr(755,root,root) %{_libdir}/libopencl-clang.so.11
+%ghost %attr(755,root,root) %{_libdir}/libopencl-clang.so.12
 
 %files devel
 %defattr(644,root,root,755)
This page took 0.135431 seconds and 4 git commands to generate.