]> git.pld-linux.org Git - packages/opencl-clang.git/commitdiff
up to 11.0.0 auto/th/opencl-clang-11.0.0-1
authorJan Palus <atler@pld-linux.org>
Fri, 30 Oct 2020 10:05:14 +0000 (11:05 +0100)
committerJan Palus <atler@pld-linux.org>
Fri, 30 Oct 2020 10:05:14 +0000 (11:05 +0100)
llvm10.patch [deleted file]
opencl-clang.spec

diff --git a/llvm10.patch b/llvm10.patch
deleted file mode 100644 (file)
index 5a4c3df..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
---- opencl-clang-10.0.0/CMakeLists.txt.orig    2020-04-10 16:29:26.493507026 +0200
-+++ opencl-clang-10.0.0/CMakeLists.txt 2020-04-10 16:32:55.252632824 +0200
-@@ -218,6 +218,10 @@
- set(LLVM_REQUIRES_EH ON)
-+if(LLVM_PACKAGE_VERSION VERSION_GREATER_EQUAL 10.0.0 AND Polly IN_LIST LLVM_AVAILABLE_LIBS)
-+  list(APPEND ADDITIONAL_LIBS Polly)
-+endif()
-+
- add_llvm_library(${TARGET_NAME} SHARED
-   ${TARGET_INCLUDE_FILES}
-   ${TARGET_SOURCE_FILES}
index 235dd5f435e3c95e68588937c664dc91d522928b..d11fc3f7d78786584ece2b02bf271bc4455fdab8 100644 (file)
@@ -1,18 +1,17 @@
 
 # requires the OpenCL patches
-%define llvm_version 10.0.0
+%define llvm_version 11.0.0
 
-%define spirv_llvm_translator_version 10.0.0
+%define spirv_llvm_translator_version 11.0.0
 
 Summary:       Intel Graphics Compute Runtime for OpenCL
 Name:          opencl-clang
-Version:       10.0.0
-Release:       2
+Version:       11.0.0
+Release:       1
 License:       University of Illinois/NCSA Open Source License
 Group:         Libraries
 Source0:       https://github.com/intel/opencl-clang/archive/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: a28bc82341f0ef4dbf749d2ee5e0a907
-Patch0:                llvm10.patch
+# Source0-md5: 31e0ca207e06d6bb1a49661cafd8a3ea
 URL:           https://01.org/compute-runtime
 BuildRequires: SPIRV-LLVM-Translator-devel >= %{spirv_llvm_translator_version}
 BuildRequires: clang >= %{llvm_rpm_version}
@@ -42,7 +41,6 @@ Pliki nagłówkowe biblioteki %{name}.
 
 %prep
 %setup -q
-%patch0 -p1
 
 %build
 install -d build
@@ -64,8 +62,8 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
-mv $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.10 $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.%{llvm_version}
-ln -s libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.10
+mv $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.11 $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.%{llvm_version}
+ln -s libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.11
 ln -sf libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so
 
 %post  -p /sbin/ldconfig
@@ -78,7 +76,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc README.md
 %attr(755,root,root) %{_libdir}/libopencl-clang.so.%{llvm_version}
-%ghost %attr(755,root,root) %{_libdir}/libopencl-clang.so.10
+%ghost %attr(755,root,root) %{_libdir}/libopencl-clang.so.11
 
 %files devel
 %defattr(644,root,root,755)
This page took 0.140691 seconds and 4 git commands to generate.