]> git.pld-linux.org Git - packages/opencl-clang.git/blobdiff - opencl-clang.spec
up to 13.0.0
[packages/opencl-clang.git] / opencl-clang.spec
index ff016496be3280f79007153818d585a961c9fe9e..d7457791ed2f712cd83d2c419e35311c18f2bbfe 100644 (file)
@@ -1,18 +1,17 @@
 
 # requires the OpenCL patches
-%define llvm_version 10.0.0
+%define llvm_version 13.0.0
 
-%define spirv_llvm_translator_version 10.0.0
+%define spirv_llvm_translator_version 13.0.0
 
 Summary:       Intel Graphics Compute Runtime for OpenCL
 Name:          opencl-clang
-Version:       10.0.0
+Version:       13.0.0
 Release:       1
 License:       University of Illinois/NCSA Open Source License
 Group:         Libraries
 Source0:       https://github.com/intel/opencl-clang/archive/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: a28bc82341f0ef4dbf749d2ee5e0a907
-Patch0:                llvm10.patch
+# Source0-md5: 6e719b1a8067ac23d2a640f43feb046e
 URL:           https://01.org/compute-runtime
 BuildRequires: SPIRV-LLVM-Translator-devel >= %{spirv_llvm_translator_version}
 BuildRequires: clang >= %{llvm_rpm_version}
@@ -20,6 +19,7 @@ BuildRequires:        clang-devel >= %{llvm_version}
 BuildRequires: cmake >= 3.4.3
 BuildRequires: llvm-devel >= %{llvm_version}
 BuildRequires: pkgconfig
+BuildRequires: rpmbuild(macros) >= 1.605
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -42,7 +42,6 @@ Pliki nagłówkowe biblioteki %{name}.
 
 %prep
 %setup -q
-%patch0 -p1
 
 %build
 install -d build
@@ -64,8 +63,8 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
-mv $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.10 $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.%{llvm_version}
-ln -s libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.10
+mv $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.13 $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.%{llvm_version}
+ln -s libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.13
 ln -sf libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so
 
 %post  -p /sbin/ldconfig
@@ -78,7 +77,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc README.md
 %attr(755,root,root) %{_libdir}/libopencl-clang.so.%{llvm_version}
-%ghost %attr(755,root,root) %{_libdir}/libopencl-clang.so.10
+%ghost %attr(755,root,root) %{_libdir}/libopencl-clang.so.13
 
 %files devel
 %defattr(644,root,root,755)
This page took 0.037831 seconds and 4 git commands to generate.