]> git.pld-linux.org Git - packages/opencl-clang.git/blobdiff - opencl-clang.spec
up to 13.0.0
[packages/opencl-clang.git] / opencl-clang.spec
index 46ff2f789d82891ab5c23aca1e4a7dfb0e2ef0f0..d7457791ed2f712cd83d2c419e35311c18f2bbfe 100644 (file)
@@ -1,20 +1,17 @@
 
 # requires the OpenCL patches
-%define llvm_version 12.0.0
+%define llvm_version 13.0.0
 
-%define spirv_llvm_translator_version 12.0.0
-
-%define        gitref  1d1829d930d31309c43512fc17ece51dd314ebde
-%define        snap    20210525
+%define spirv_llvm_translator_version 13.0.0
 
 Summary:       Intel Graphics Compute Runtime for OpenCL
 Name:          opencl-clang
-Version:       12.0.0
-Release:       0.%{snap}.1
+Version:       13.0.0
+Release:       1
 License:       University of Illinois/NCSA Open Source License
 Group:         Libraries
-Source0:       https://github.com/intel/opencl-clang/archive/%{gitref}/%{name}-%{snap}.tar.gz
-# Source0-md5: aa6983d5d43d2d92727837a8c1669c9f
+Source0:       https://github.com/intel/opencl-clang/archive/v%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: 6e719b1a8067ac23d2a640f43feb046e
 URL:           https://01.org/compute-runtime
 BuildRequires: SPIRV-LLVM-Translator-devel >= %{spirv_llvm_translator_version}
 BuildRequires: clang >= %{llvm_rpm_version}
@@ -22,6 +19,7 @@ BuildRequires:        clang-devel >= %{llvm_version}
 BuildRequires: cmake >= 3.4.3
 BuildRequires: llvm-devel >= %{llvm_version}
 BuildRequires: pkgconfig
+BuildRequires: rpmbuild(macros) >= 1.605
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -43,7 +41,7 @@ Header files for %{name} library.
 Pliki nagłówkowe biblioteki %{name}.
 
 %prep
-%setup -q -n %{name}-%{gitref}
+%setup -q
 
 %build
 install -d build
@@ -65,8 +63,8 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
-mv $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.12 $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.%{llvm_version}
-ln -s libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.12
+mv $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.13 $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.%{llvm_version}
+ln -s libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.13
 ln -sf libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so
 
 %post  -p /sbin/ldconfig
@@ -79,7 +77,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc README.md
 %attr(755,root,root) %{_libdir}/libopencl-clang.so.%{llvm_version}
-%ghost %attr(755,root,root) %{_libdir}/libopencl-clang.so.12
+%ghost %attr(755,root,root) %{_libdir}/libopencl-clang.so.13
 
 %files devel
 %defattr(644,root,root,755)
This page took 0.054123 seconds and 4 git commands to generate.