]> git.pld-linux.org Git - packages/opencl-clang.git/blobdiff - opencl-clang.spec
up to 18.1.0
[packages/opencl-clang.git] / opencl-clang.spec
index 235dd5f435e3c95e68588937c664dc91d522928b..f4313622d1edf206b2a9764d4cbe992888f8a14c 100644 (file)
@@ -1,25 +1,25 @@
 
 # requires the OpenCL patches
 
 # requires the OpenCL patches
-%define llvm_version 10.0.0
-
-%define spirv_llvm_translator_version 10.0.0
+%define llvm_version                   18.1.0
+%define spirv_llvm_translator_version  18.1.0
 
 Summary:       Intel Graphics Compute Runtime for OpenCL
 
 Summary:       Intel Graphics Compute Runtime for OpenCL
+Summary(pl.UTF-8):     Biblioteki uruchomieniowe Intel Graphics Compute dla OpenCL
 Name:          opencl-clang
 Name:          opencl-clang
-Version:       10.0.0
-Release:       2
+Version:       18.1.0
+Release:       1
 License:       University of Illinois/NCSA Open Source License
 Group:         Libraries
 Source0:       https://github.com/intel/opencl-clang/archive/v%{version}/%{name}-%{version}.tar.gz
 License:       University of Illinois/NCSA Open Source License
 Group:         Libraries
 Source0:       https://github.com/intel/opencl-clang/archive/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: a28bc82341f0ef4dbf749d2ee5e0a907
-Patch0:                llvm10.patch
+# Source0-md5: bc489b3d1222c1c637fd777bc056b5af
 URL:           https://01.org/compute-runtime
 BuildRequires: SPIRV-LLVM-Translator-devel >= %{spirv_llvm_translator_version}
 BuildRequires: clang >= %{llvm_rpm_version}
 BuildRequires: clang-devel >= %{llvm_version}
 URL:           https://01.org/compute-runtime
 BuildRequires: SPIRV-LLVM-Translator-devel >= %{spirv_llvm_translator_version}
 BuildRequires: clang >= %{llvm_rpm_version}
 BuildRequires: clang-devel >= %{llvm_version}
-BuildRequires: cmake >= 3.4.3
+BuildRequires: cmake >= 3.13.4
 BuildRequires: llvm-devel >= %{llvm_version}
 BuildRequires: pkgconfig
 BuildRequires: llvm-devel >= %{llvm_version}
 BuildRequires: pkgconfig
+BuildRequires: rpmbuild(macros) >= 1.605
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -27,6 +27,11 @@ Common clang is a thin wrapper library around clang. Common clang has
 OpenCL-oriented API and is capable to compile OpenCL C kernels to
 SPIR-V modules.
 
 OpenCL-oriented API and is capable to compile OpenCL C kernels to
 SPIR-V modules.
 
+%description -l pl.UTF-8
+Common clang to niewielka biblioteka obudowująca clanga. Ma API
+zorientowane na OpenCL i potrafi kompilować jądra C OpenCL do modułów
+WPIR-V
+
 %package devel
 Summary:       Header files for %{name} library
 Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki %{name}
 %package devel
 Summary:       Header files for %{name} library
 Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki %{name}
@@ -42,7 +47,6 @@ Pliki nagłówkowe biblioteki %{name}.
 
 %prep
 %setup -q
 
 %prep
 %setup -q
-%patch0 -p1
 
 %build
 install -d build
 
 %build
 install -d build
@@ -64,8 +68,8 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
 %{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
-mv $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.10 $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.%{llvm_version}
-ln -s libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.10
+%{__mv} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.18.1 $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.%{llvm_version}
+ln -s libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.18.1
 ln -sf libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so
 
 %post  -p /sbin/ldconfig
 ln -sf libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so
 
 %post  -p /sbin/ldconfig
@@ -78,7 +82,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc README.md
 %attr(755,root,root) %{_libdir}/libopencl-clang.so.%{llvm_version}
 %defattr(644,root,root,755)
 %doc README.md
 %attr(755,root,root) %{_libdir}/libopencl-clang.so.%{llvm_version}
-%ghost %attr(755,root,root) %{_libdir}/libopencl-clang.so.10
+%ghost %attr(755,root,root) %{_libdir}/libopencl-clang.so.18.1
 
 %files devel
 %defattr(644,root,root,755)
 
 %files devel
 %defattr(644,root,root,755)
This page took 0.105605 seconds and 4 git commands to generate.