]> git.pld-linux.org Git - packages/opencl-clang.git/blobdiff - opencl-clang.spec
- release 2 (by relup.sh)
[packages/opencl-clang.git] / opencl-clang.spec
index a48bf6790cb50242679ca61393ec0ea9abc56d45..ac0bffa0b193b7ea58418fda360862618b368ce5 100644 (file)
@@ -1,25 +1,23 @@
 
 # requires the OpenCL patches
-%define llvm_version 7.0.1
-%define llvm_rpm_version %{llvm_version}-3
+%define llvm_version 9.0.0
 
-%define spirv_llvm_translator_version 7.0.1
+%define spirv_llvm_translator_version 9.0.0
 
 Summary:       Intel Graphics Compute Runtime for OpenCL
 Name:          opencl-clang
-Version:       8.0.1
-Release:       1
+Version:       9.0.0
+Release:       2
 License:       University of Illinois/NCSA Open Source License
 Group:         Libraries
 Source0:       https://github.com/intel/opencl-clang/archive/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: cb6b746c837a6cac6c8906911b2ea9de
-Patch0:                llvm_clang_vfs.patch
+# Source0-md5: ca856bc6ec05fcf3a7d8374d97904b28
 URL:           https://01.org/compute-runtime
 BuildRequires: SPIRV-LLVM-Translator-devel >= %{spirv_llvm_translator_version}
 BuildRequires: clang >= %{llvm_rpm_version}
-BuildRequires: clang-devel >= %{llvm_rpm_version}
+BuildRequires: clang-devel >= %{llvm_version}
 BuildRequires: cmake >= 3.4.3
-BuildRequires: llvm-devel >= %{llvm_rpm_version}
+BuildRequires: llvm-devel >= %{llvm_version}
 BuildRequires: pkgconfig
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -44,8 +42,6 @@ Pliki nagłówkowe biblioteki %{name}.
 %prep
 %setup -q
 
-%patch0 -p1
-
 %build
 install -d build
 cd build
@@ -66,8 +62,8 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
-mv $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.7 $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.%{llvm_version}
-ln -s libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.7
+mv $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.9 $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.%{llvm_version}
+ln -s libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.9
 ln -sf libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so
 
 %post  -p /sbin/ldconfig
@@ -80,7 +76,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc README.md
 %attr(755,root,root) %{_libdir}/libopencl-clang.so.%{llvm_version}
-%ghost %attr(755,root,root) %{_libdir}/libopencl-clang.so.7
+%ghost %attr(755,root,root) %{_libdir}/libopencl-clang.so.9
 
 %files devel
 %defattr(644,root,root,755)
This page took 0.056666 seconds and 4 git commands to generate.