]> git.pld-linux.org Git - packages/opencl-clang.git/blobdiff - opencl-clang.spec
up to 18.1.0
[packages/opencl-clang.git] / opencl-clang.spec
index c2a1f68746b14ac3984afa53474878f1d4ca738d..f4313622d1edf206b2a9764d4cbe992888f8a14c 100644 (file)
@@ -1,22 +1,22 @@
 
 # requires the OpenCL patches
-%define llvm_version                   14.0.0
-%define spirv_llvm_translator_version  14.0.0
+%define llvm_version                   18.1.0
+%define spirv_llvm_translator_version  18.1.0
 
 Summary:       Intel Graphics Compute Runtime for OpenCL
 Summary(pl.UTF-8):     Biblioteki uruchomieniowe Intel Graphics Compute dla OpenCL
 Name:          opencl-clang
-Version:       14.0.0
-Release:       2
+Version:       18.1.0
+Release:       1
 License:       University of Illinois/NCSA Open Source License
 Group:         Libraries
 Source0:       https://github.com/intel/opencl-clang/archive/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: c12fe86fd498c1c5a2e2be2129339584
+# Source0-md5: bc489b3d1222c1c637fd777bc056b5af
 URL:           https://01.org/compute-runtime
 BuildRequires: SPIRV-LLVM-Translator-devel >= %{spirv_llvm_translator_version}
 BuildRequires: clang >= %{llvm_rpm_version}
 BuildRequires: clang-devel >= %{llvm_version}
-BuildRequires: cmake >= 3.4.3
+BuildRequires: cmake >= 3.13.4
 BuildRequires: llvm-devel >= %{llvm_version}
 BuildRequires: pkgconfig
 BuildRequires: rpmbuild(macros) >= 1.605
@@ -68,8 +68,8 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
-%{__mv} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.14 $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.%{llvm_version}
-ln -s libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.14
+%{__mv} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.18.1 $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.%{llvm_version}
+ln -s libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.18.1
 ln -sf libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so
 
 %post  -p /sbin/ldconfig
@@ -82,7 +82,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc README.md
 %attr(755,root,root) %{_libdir}/libopencl-clang.so.%{llvm_version}
-%ghost %attr(755,root,root) %{_libdir}/libopencl-clang.so.14
+%ghost %attr(755,root,root) %{_libdir}/libopencl-clang.so.18.1
 
 %files devel
 %defattr(644,root,root,755)
This page took 0.031543 seconds and 4 git commands to generate.