]> git.pld-linux.org Git - packages/opencl-clang.git/blobdiff - opencl-clang.spec
- llvm rebuild
[packages/opencl-clang.git] / opencl-clang.spec
index 4d40b63766e1ae103f927ca9c3252b77d22b1b4b..31f2ffca85211c4a59e9061d4761bd57eef492f7 100644 (file)
@@ -1,25 +1,24 @@
 
-%define llvm_version 7.0.1
-%define spirv_llvm_translator_version 7.0.1
+# requires the OpenCL patches
+%define llvm_version 11.0.0
+
+%define spirv_llvm_translator_version 11.0.0
 
 Summary:       Intel Graphics Compute Runtime for OpenCL
 Name:          opencl-clang
-Version:       8.0.1
-Release:       1
+Version:       11.0.0
+Release:       3
 License:       University of Illinois/NCSA Open Source License
 Group:         Libraries
 Source0:       https://github.com/intel/opencl-clang/archive/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: cb6b746c837a6cac6c8906911b2ea9de
-Patch0:                llvm_clang_vfs.patch
+# Source0-md5: 31e0ca207e06d6bb1a49661cafd8a3ea
 URL:           https://01.org/compute-runtime
-BuildRequires: SPIRV-LLVM-Translator >= %{spirv_llvm_translator_version}
-BuildRequires: clang >= %{llvm_version}
+BuildRequires: SPIRV-LLVM-Translator-devel >= %{spirv_llvm_translator_version}
+BuildRequires: clang >= %{llvm_rpm_version}
 BuildRequires: clang-devel >= %{llvm_version}
 BuildRequires: cmake >= 3.4.3
 BuildRequires: llvm-devel >= %{llvm_version}
 BuildRequires: pkgconfig
-%requires_eq   clang
-%requires_eq   clang-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -31,6 +30,7 @@ SPIR-V modules.
 Summary:       Header files for %{name} library
 Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki %{name}
 Group:         Development/Libraries
+%requires_eq   clang-devel
 Requires:      %{name} = %{version}-%{release}
 
 %description devel
@@ -42,8 +42,6 @@ Pliki nagłówkowe biblioteki %{name}.
 %prep
 %setup -q
 
-%patch0 -p1
-
 %build
 install -d build
 cd build
@@ -52,6 +50,7 @@ cd build
        -DPREFERRED_LLVM_VERSION="%{llvm_version}" \
        -DLLVMSPIRV_INCLUDED_IN_LLVM=OFF \
        -DSPIRV_TRANSLATOR_DIR="%{_prefix}" \
+       -DGIT_EXECUTABLE=/bin/false \
        ../
 %{__make}
 
@@ -63,8 +62,8 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
-mv $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.7 $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.%{llvm_version}
-ln -s libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.7
+mv $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.11 $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.%{llvm_version}
+ln -s libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.11
 ln -sf libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so
 
 %post  -p /sbin/ldconfig
@@ -77,7 +76,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc README.md
 %attr(755,root,root) %{_libdir}/libopencl-clang.so.%{llvm_version}
-%ghost %attr(755,root,root) %{_libdir}/libopencl-clang.so.7
+%ghost %attr(755,root,root) %{_libdir}/libopencl-clang.so.11
 
 %files devel
 %defattr(644,root,root,755)
This page took 0.186947 seconds and 4 git commands to generate.