]> git.pld-linux.org Git - packages/opencl-clang.git/blobdiff - opencl-clang.spec
- llvm rebuild
[packages/opencl-clang.git] / opencl-clang.spec
index 6fbee66a6e30a6672cf5abc8c452352398b746f1..235dd5f435e3c95e68588937c664dc91d522928b 100644 (file)
@@ -1,18 +1,18 @@
 
 # requires the OpenCL patches
-%define llvm_version 8.0.1
+%define llvm_version 10.0.0
 
-%define spirv_llvm_translator_version 8.0.1
+%define spirv_llvm_translator_version 10.0.0
 
 Summary:       Intel Graphics Compute Runtime for OpenCL
 Name:          opencl-clang
-Version:       8.0.1
+Version:       10.0.0
 Release:       2
 License:       University of Illinois/NCSA Open Source License
 Group:         Libraries
 Source0:       https://github.com/intel/opencl-clang/archive/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: cb6b746c837a6cac6c8906911b2ea9de
-Patch0:                align-with-modified-llvm-writespirv-api.patch
+# Source0-md5: a28bc82341f0ef4dbf749d2ee5e0a907
+Patch0:                llvm10.patch
 URL:           https://01.org/compute-runtime
 BuildRequires: SPIRV-LLVM-Translator-devel >= %{spirv_llvm_translator_version}
 BuildRequires: clang >= %{llvm_rpm_version}
@@ -64,8 +64,8 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
-mv $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.8 $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.%{llvm_version}
-ln -s libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.8
+mv $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.10 $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.%{llvm_version}
+ln -s libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.10
 ln -sf libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so
 
 %post  -p /sbin/ldconfig
@@ -78,7 +78,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc README.md
 %attr(755,root,root) %{_libdir}/libopencl-clang.so.%{llvm_version}
-%ghost %attr(755,root,root) %{_libdir}/libopencl-clang.so.8
+%ghost %attr(755,root,root) %{_libdir}/libopencl-clang.so.10
 
 %files devel
 %defattr(644,root,root,755)
This page took 0.09246 seconds and 4 git commands to generate.