]> git.pld-linux.org Git - packages/opencl-clang.git/blob - opencl-clang.spec
adjust for llvm 8 and spirv translator 8; rel 2
[packages/opencl-clang.git] / opencl-clang.spec
1
2 # requires the OpenCL patches
3 %define llvm_version 8.0.1
4
5 %define spirv_llvm_translator_version 8.0.1
6
7 Summary:        Intel Graphics Compute Runtime for OpenCL
8 Name:           opencl-clang
9 Version:        8.0.1
10 Release:        2
11 License:        University of Illinois/NCSA Open Source License
12 Group:          Libraries
13 Source0:        https://github.com/intel/opencl-clang/archive/v%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  cb6b746c837a6cac6c8906911b2ea9de
15 Patch0:         align-with-modified-llvm-writespirv-api.patch
16 URL:            https://01.org/compute-runtime
17 BuildRequires:  SPIRV-LLVM-Translator-devel >= %{spirv_llvm_translator_version}
18 BuildRequires:  clang >= %{llvm_rpm_version}
19 BuildRequires:  clang-devel >= %{llvm_version}
20 BuildRequires:  cmake >= 3.4.3
21 BuildRequires:  llvm-devel >= %{llvm_version}
22 BuildRequires:  pkgconfig
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Common clang is a thin wrapper library around clang. Common clang has
27 OpenCL-oriented API and is capable to compile OpenCL C kernels to
28 SPIR-V modules.
29
30 %package devel
31 Summary:        Header files for %{name} library
32 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
33 Group:          Development/Libraries
34 %requires_eq    clang-devel
35 Requires:       %{name} = %{version}-%{release}
36
37 %description devel
38 Header files for %{name} library.
39
40 %description devel -l pl.UTF-8
41 Pliki nagłówkowe biblioteki %{name}.
42
43 %prep
44 %setup -q
45 %patch0 -p1
46
47 %build
48 install -d build
49 cd build
50 %cmake \
51         -DUSE_PREBUILT_LLVM=ON \
52         -DPREFERRED_LLVM_VERSION="%{llvm_version}" \
53         -DLLVMSPIRV_INCLUDED_IN_LLVM=OFF \
54         -DSPIRV_TRANSLATOR_DIR="%{_prefix}" \
55         -DGIT_EXECUTABLE=/bin/false \
56         ../
57 %{__make}
58
59 cd ..
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 %{__make} -C build install \
65         DESTDIR=$RPM_BUILD_ROOT
66
67 mv $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.8 $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.%{llvm_version}
68 ln -s libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.8
69 ln -sf libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so
70
71 %post   -p /sbin/ldconfig
72 %postun -p /sbin/ldconfig
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %doc README.md
80 %attr(755,root,root) %{_libdir}/libopencl-clang.so.%{llvm_version}
81 %ghost %attr(755,root,root) %{_libdir}/libopencl-clang.so.8
82
83 %files devel
84 %defattr(644,root,root,755)
85 %attr(755,root,root) %{_libdir}/libopencl-clang.so
86 %{_includedir}/cclang
This page took 0.078237 seconds and 4 git commands to generate.