]> git.pld-linux.org Git - packages/opencl-clang.git/blob - opencl-clang.spec
e694d8dd78fa9e2c25329fdb385e0b29424aa28f
[packages/opencl-clang.git] / opencl-clang.spec
1
2 # requires the OpenCL patches
3 %define llvm_version 12.0.0
4
5 %define spirv_llvm_translator_version 12.0.0
6
7 Summary:        Intel Graphics Compute Runtime for OpenCL
8 Name:           opencl-clang
9 Version:        12.0.0
10 Release:        2
11 License:        University of Illinois/NCSA Open Source License
12 Group:          Libraries
13 Source0:        https://github.com/intel/opencl-clang/archive/v%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  e8abbdba2d39f3f090d949dd8fc4737b
15 URL:            https://01.org/compute-runtime
16 BuildRequires:  SPIRV-LLVM-Translator-devel >= %{spirv_llvm_translator_version}
17 BuildRequires:  clang >= %{llvm_rpm_version}
18 BuildRequires:  clang-devel >= %{llvm_version}
19 BuildRequires:  cmake >= 3.4.3
20 BuildRequires:  llvm-devel >= %{llvm_version}
21 BuildRequires:  pkgconfig
22 BuildRequires:  rpmbuild(macros) >= 1.605
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Common clang is a thin wrapper library around clang. Common clang has
27 OpenCL-oriented API and is capable to compile OpenCL C kernels to
28 SPIR-V modules.
29
30 %package devel
31 Summary:        Header files for %{name} library
32 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
33 Group:          Development/Libraries
34 %requires_eq    clang-devel
35 Requires:       %{name} = %{version}-%{release}
36
37 %description devel
38 Header files for %{name} library.
39
40 %description devel -l pl.UTF-8
41 Pliki nagłówkowe biblioteki %{name}.
42
43 %prep
44 %setup -q
45
46 %build
47 install -d build
48 cd build
49 %cmake \
50         -DUSE_PREBUILT_LLVM=ON \
51         -DPREFERRED_LLVM_VERSION="%{llvm_version}" \
52         -DLLVMSPIRV_INCLUDED_IN_LLVM=OFF \
53         -DSPIRV_TRANSLATOR_DIR="%{_prefix}" \
54         -DGIT_EXECUTABLE=/bin/false \
55         ../
56 %{__make}
57
58 cd ..
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 %{__make} -C build install \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 mv $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.12 $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.%{llvm_version}
67 ln -s libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.12
68 ln -sf libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so
69
70 %post   -p /sbin/ldconfig
71 %postun -p /sbin/ldconfig
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc README.md
79 %attr(755,root,root) %{_libdir}/libopencl-clang.so.%{llvm_version}
80 %ghost %attr(755,root,root) %{_libdir}/libopencl-clang.so.12
81
82 %files devel
83 %defattr(644,root,root,755)
84 %attr(755,root,root) %{_libdir}/libopencl-clang.so
85 %{_includedir}/cclang
This page took 0.067523 seconds and 3 git commands to generate.