]> git.pld-linux.org Git - packages/opencl-clang.git/blob - opencl-clang.spec
46ff2f789d82891ab5c23aca1e4a7dfb0e2ef0f0
[packages/opencl-clang.git] / opencl-clang.spec
1
2 # requires the OpenCL patches
3 %define llvm_version 12.0.0
4
5 %define spirv_llvm_translator_version 12.0.0
6
7 %define gitref  1d1829d930d31309c43512fc17ece51dd314ebde
8 %define snap    20210525
9
10 Summary:        Intel Graphics Compute Runtime for OpenCL
11 Name:           opencl-clang
12 Version:        12.0.0
13 Release:        0.%{snap}.1
14 License:        University of Illinois/NCSA Open Source License
15 Group:          Libraries
16 Source0:        https://github.com/intel/opencl-clang/archive/%{gitref}/%{name}-%{snap}.tar.gz
17 # Source0-md5:  aa6983d5d43d2d92727837a8c1669c9f
18 URL:            https://01.org/compute-runtime
19 BuildRequires:  SPIRV-LLVM-Translator-devel >= %{spirv_llvm_translator_version}
20 BuildRequires:  clang >= %{llvm_rpm_version}
21 BuildRequires:  clang-devel >= %{llvm_version}
22 BuildRequires:  cmake >= 3.4.3
23 BuildRequires:  llvm-devel >= %{llvm_version}
24 BuildRequires:  pkgconfig
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Common clang is a thin wrapper library around clang. Common clang has
29 OpenCL-oriented API and is capable to compile OpenCL C kernels to
30 SPIR-V modules.
31
32 %package devel
33 Summary:        Header files for %{name} library
34 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
35 Group:          Development/Libraries
36 %requires_eq    clang-devel
37 Requires:       %{name} = %{version}-%{release}
38
39 %description devel
40 Header files for %{name} library.
41
42 %description devel -l pl.UTF-8
43 Pliki nagłówkowe biblioteki %{name}.
44
45 %prep
46 %setup -q -n %{name}-%{gitref}
47
48 %build
49 install -d build
50 cd build
51 %cmake \
52         -DUSE_PREBUILT_LLVM=ON \
53         -DPREFERRED_LLVM_VERSION="%{llvm_version}" \
54         -DLLVMSPIRV_INCLUDED_IN_LLVM=OFF \
55         -DSPIRV_TRANSLATOR_DIR="%{_prefix}" \
56         -DGIT_EXECUTABLE=/bin/false \
57         ../
58 %{__make}
59
60 cd ..
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 %{__make} -C build install \
66         DESTDIR=$RPM_BUILD_ROOT
67
68 mv $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.12 $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.%{llvm_version}
69 ln -s libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.12
70 ln -sf libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so
71
72 %post   -p /sbin/ldconfig
73 %postun -p /sbin/ldconfig
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %doc README.md
81 %attr(755,root,root) %{_libdir}/libopencl-clang.so.%{llvm_version}
82 %ghost %attr(755,root,root) %{_libdir}/libopencl-clang.so.12
83
84 %files devel
85 %defattr(644,root,root,755)
86 %attr(755,root,root) %{_libdir}/libopencl-clang.so
87 %{_includedir}/cclang
This page took 0.046515 seconds and 2 git commands to generate.