]> git.pld-linux.org Git - packages/opencl-clang.git/blame_incremental - opencl-clang.spec
macros for %cmake
[packages/opencl-clang.git] / opencl-clang.spec
... / ...
CommitLineData
1
2# requires the OpenCL patches
3%define llvm_version 12.0.0
4
5%define spirv_llvm_translator_version 12.0.0
6
7%define gitref 1d1829d930d31309c43512fc17ece51dd314ebde
8%define snap 20210525
9
10Summary: Intel Graphics Compute Runtime for OpenCL
11Name: opencl-clang
12Version: 12.0.0
13Release: 0.%{snap}.1
14License: University of Illinois/NCSA Open Source License
15Group: Libraries
16Source0: https://github.com/intel/opencl-clang/archive/%{gitref}/%{name}-%{snap}.tar.gz
17# Source0-md5: aa6983d5d43d2d92727837a8c1669c9f
18URL: https://01.org/compute-runtime
19BuildRequires: SPIRV-LLVM-Translator-devel >= %{spirv_llvm_translator_version}
20BuildRequires: clang >= %{llvm_rpm_version}
21BuildRequires: clang-devel >= %{llvm_version}
22BuildRequires: cmake >= 3.4.3
23BuildRequires: llvm-devel >= %{llvm_version}
24BuildRequires: pkgconfig
25BuildRequires: rpmbuild(macros) >= 1.605
26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28%description
29Common clang is a thin wrapper library around clang. Common clang has
30OpenCL-oriented API and is capable to compile OpenCL C kernels to
31SPIR-V modules.
32
33%package devel
34Summary: Header files for %{name} library
35Summary(pl.UTF-8): Pliki nagłówkowe biblioteki %{name}
36Group: Development/Libraries
37%requires_eq clang-devel
38Requires: %{name} = %{version}-%{release}
39
40%description devel
41Header files for %{name} library.
42
43%description devel -l pl.UTF-8
44Pliki nagłówkowe biblioteki %{name}.
45
46%prep
47%setup -q -n %{name}-%{gitref}
48
49%build
50install -d build
51cd build
52%cmake \
53 -DUSE_PREBUILT_LLVM=ON \
54 -DPREFERRED_LLVM_VERSION="%{llvm_version}" \
55 -DLLVMSPIRV_INCLUDED_IN_LLVM=OFF \
56 -DSPIRV_TRANSLATOR_DIR="%{_prefix}" \
57 -DGIT_EXECUTABLE=/bin/false \
58 ../
59%{__make}
60
61cd ..
62
63%install
64rm -rf $RPM_BUILD_ROOT
65
66%{__make} -C build install \
67 DESTDIR=$RPM_BUILD_ROOT
68
69mv $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.12 $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.%{llvm_version}
70ln -s libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.12
71ln -sf libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so
72
73%post -p /sbin/ldconfig
74%postun -p /sbin/ldconfig
75
76%clean
77rm -rf $RPM_BUILD_ROOT
78
79%files
80%defattr(644,root,root,755)
81%doc README.md
82%attr(755,root,root) %{_libdir}/libopencl-clang.so.%{llvm_version}
83%ghost %attr(755,root,root) %{_libdir}/libopencl-clang.so.12
84
85%files devel
86%defattr(644,root,root,755)
87%attr(755,root,root) %{_libdir}/libopencl-clang.so
88%{_includedir}/cclang
This page took 0.038772 seconds and 4 git commands to generate.