]> git.pld-linux.org Git - packages/opencl-clang.git/blame_incremental - opencl-clang.spec
up to 13.0.0
[packages/opencl-clang.git] / opencl-clang.spec
... / ...
CommitLineData
1
2# requires the OpenCL patches
3%define llvm_version 13.0.0
4
5%define spirv_llvm_translator_version 13.0.0
6
7Summary: Intel Graphics Compute Runtime for OpenCL
8Name: opencl-clang
9Version: 13.0.0
10Release: 1
11License: University of Illinois/NCSA Open Source License
12Group: Libraries
13Source0: https://github.com/intel/opencl-clang/archive/v%{version}/%{name}-%{version}.tar.gz
14# Source0-md5: 6e719b1a8067ac23d2a640f43feb046e
15URL: https://01.org/compute-runtime
16BuildRequires: SPIRV-LLVM-Translator-devel >= %{spirv_llvm_translator_version}
17BuildRequires: clang >= %{llvm_rpm_version}
18BuildRequires: clang-devel >= %{llvm_version}
19BuildRequires: cmake >= 3.4.3
20BuildRequires: llvm-devel >= %{llvm_version}
21BuildRequires: pkgconfig
22BuildRequires: rpmbuild(macros) >= 1.605
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26Common clang is a thin wrapper library around clang. Common clang has
27OpenCL-oriented API and is capable to compile OpenCL C kernels to
28SPIR-V modules.
29
30%package devel
31Summary: Header files for %{name} library
32Summary(pl.UTF-8): Pliki nagłówkowe biblioteki %{name}
33Group: Development/Libraries
34%requires_eq clang-devel
35Requires: %{name} = %{version}-%{release}
36
37%description devel
38Header files for %{name} library.
39
40%description devel -l pl.UTF-8
41Pliki nagłówkowe biblioteki %{name}.
42
43%prep
44%setup -q
45
46%build
47install -d build
48cd build
49%cmake \
50 -DUSE_PREBUILT_LLVM=ON \
51 -DPREFERRED_LLVM_VERSION="%{llvm_version}" \
52 -DLLVMSPIRV_INCLUDED_IN_LLVM=OFF \
53 -DSPIRV_TRANSLATOR_DIR="%{_prefix}" \
54 -DGIT_EXECUTABLE=/bin/false \
55 ../
56%{__make}
57
58cd ..
59
60%install
61rm -rf $RPM_BUILD_ROOT
62
63%{__make} -C build install \
64 DESTDIR=$RPM_BUILD_ROOT
65
66mv $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.13 $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.%{llvm_version}
67ln -s libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so.13
68ln -sf libopencl-clang.so.%{llvm_version} $RPM_BUILD_ROOT%{_libdir}/libopencl-clang.so
69
70%post -p /sbin/ldconfig
71%postun -p /sbin/ldconfig
72
73%clean
74rm -rf $RPM_BUILD_ROOT
75
76%files
77%defattr(644,root,root,755)
78%doc README.md
79%attr(755,root,root) %{_libdir}/libopencl-clang.so.%{llvm_version}
80%ghost %attr(755,root,root) %{_libdir}/libopencl-clang.so.13
81
82%files devel
83%defattr(644,root,root,755)
84%attr(755,root,root) %{_libdir}/libopencl-clang.so
85%{_includedir}/cclang
This page took 0.053631 seconds and 4 git commands to generate.