]> git.pld-linux.org Git - packages/ocaml.git/commitdiff
- up to 4.04.1
authorJan Rękorajski <baggins@pld-linux.org>
Mon, 5 Jun 2017 09:26:21 +0000 (11:26 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Mon, 5 Jun 2017 09:26:21 +0000 (11:26 +0200)
ocaml-CFLAGS.patch
ocaml.spec
x32.patch

index 0a54b6a4acd5286df670785be90b0a415bf541de..bc822802ca4b42fe9f2579ee05a4444b02920521 100644 (file)
@@ -8,20 +8,21 @@ Makefiles=$(find . -type f -name Makefile\*)
 
 --- ocaml-4.02.2/asmrun/Makefile.orig  2015-06-28 13:45:16.203456490 +0200
 +++ ocaml-4.02.2/asmrun/Makefile       2015-06-28 15:07:59.556581531 +0200
-@@ -16,10 +16,10 @@
- CC=$(NATIVECC)
- FLAGS=-I../byterun -DCAML_NAME_SPACE -DNATIVE_CODE \
-       -DTARGET_$(ARCH) -DSYS_$(SYSTEM) $(IFLEXDIR)
--CFLAGS=$(FLAGS) $(NATIVECCCOMPOPTS)
+@@ -16,11 +16,11 @@
+       -DTARGET_$(ARCH) -DMODEL_$(MODEL) -DSYS_$(SYSTEM) $(IFLEXDIR) \
+       $(LIBUNWIND_INCLUDE_FLAGS)
+ #CFLAGS=$(FLAGS) -g -O0
+-CFLAGS=$(FLAGS) -g -O0 $(NATIVECCCOMPOPTS)
 +override CFLAGS += $(FLAGS) $(NATIVECCCOMPOPTS)
  DFLAGS=$(FLAGS) -g -DDEBUG $(NATIVECCCOMPOPTS)
--PFLAGS=$(FLAGS) -pg -O -DPROFILING $(NATIVECCPROFOPTS)
--PICFLAGS=$(FLAGS) -O $(SHAREDCCCOMPOPTS) $(NATIVECCCOMPOPTS)
-+PFLAGS=$(FLAGS) $(CFLAGS) $(NATIVECCPROFOPTS)
+ IFLAGS=$(FLAGS) -DCAML_INSTR
+-PFLAGS=$(FLAGS) -pg -DPROFILING $(NATIVECCPROFOPTS) $(NATIVECCCOMPOPTS)
+-PICFLAGS=$(FLAGS) $(SHAREDCCCOMPOPTS) $(NATIVECCCOMPOPTS)
++PFLAGS=$(FLAGS) -pg -DPROFILING $(CFLAGS) $(NATIVECCPROFOPTS) $(NATIVECCCOMPOPTS)
 +PICFLAGS=$(FLAGS) $(CFLAGS) $(SHAREDCCCOMPOPTS) $(NATIVECCCOMPOPTS)
  
- COBJS=startup.o main.o fail.o roots.o globroots.o signals.o signals_asm.o \
-   misc.o freelist.o major_gc.o minor_gc.o memory.o alloc.o compare.o ints.o \
+ COBJS=startup_aux.o startup.o \
+   main.o fail.o roots.o globroots.o signals.o signals_asm.o \
 --- ocaml-4.02.1/asmrun/Makefile.nt.orig       2014-11-06 21:32:19.358167666 +0100
 +++ ocaml-4.02.1/asmrun/Makefile.nt    2014-11-07 16:19:43.681995569 +0100
 @@ -14,7 +14,7 @@
@@ -53,9 +54,9 @@ diff -ur ocaml-3.11.0/byterun/Makefile.nt ocaml-3.11.0.CFLAGS/byterun/Makefile.n
  
 -CFLAGS=-DOCAML_STDLIB_DIR='"$(LIBDIR)"' $(IFLEXDIR)
 +override CFLAGS += -DOCAML_STDLIB_DIR='"$(LIBDIR)"' $(IFLEXDIR)
+ DFLAGS=$(CFLAGS) -DDEBUG
  
  DBGO=d.$(O)
- OBJS=$(COMMONOBJS:.o=.$(O)) win32.$(O) main.$(O)
 --- ocaml-4.02.2/otherlibs/Makefile.orig       2015-06-28 13:45:16.210123156 +0200
 +++ ocaml-4.02.2/otherlibs/Makefile    2015-06-28 15:09:02.573245553 +0200
 @@ -16,7 +16,7 @@
index fa3a616345d1aecbef43a561c883bff463d18c64..ca07f8341f55cec1d3986bfbdbbb0664b7f43740 100644 (file)
 %undefine      with_ocaml_opt
 %endif
 
-%define                sver    4.02
+%define                sver    4.04
 
 Summary:       The Objective Caml compiler and programming environment
 Summary(pl.UTF-8):     Kompilator OCamla (Objective Caml) oraz środowisko programistyczne
 Name:          ocaml
-Version:       4.02.3
-Release:       5
+Version:       4.04.1
+Release:       1
 Epoch:         1
 License:       QPL v1.0 with linking exception (compiler), LGPL v2 with linking exception (library)
 Group:         Development/Languages
 Source0:       http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{version}.tar.xz
-# Source0-md5: 9115706e30dad644f8dec9dfb459a9ab
+# Source0-md5: 092139f2a256d1f3d2571f64ab475aa9
 Source1:       http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{sver}-refman-html.tar.gz
-# Source1-md5: 915a1949f7af7186e16354e9682dc1e5
+# Source1-md5: 5c58a4fce99b20e02c3208ad956bcb9d
 Source2:       http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{sver}-refman.ps.gz
-# Source2-md5: e85016fa23b6525d1d10da06010fd90a
+# Source2-md5: a408f706789b9b84b0eb68da3db05f15
 Source3:       http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{sver}-refman.info.tar.gz
-# Source3-md5: 265b7db123e925e8b7b70ca2266b4206
+# Source3-md5: 8c9df1da0e36a69817f43115fa87360c
 Source4:       https://github.com/mmottl/pure-fun/archive/v1.0.13/pure-fun-1.0.13.tar.gz
 # Source4-md5: 0a6ff033df78d0880fe4883ace025ebe
 # note: dead URL
@@ -249,9 +249,6 @@ cp -f /usr/share/automake/config.sub config/gnu
 %{__make} -j1 world bootstrap %{?with_ocaml_opt:opt.opt} \
        CFLAGS="%{rpmcflags} -Wall -DUSE_INTERP_RESULT"
 
-%{__make} -C tools objinfo \
-       CFLAGS="%{rpmcflags} -Wall -DUSE_INTERP_RESULT" -j1
-
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_includedir},%{_infodir},%{_examplesdir}/%{name}-%{version}}
@@ -296,7 +293,7 @@ for f in {asm,byte}comp parsing typing utils ; do
 done
 
 # this isn't installed by default, but is useful
-install tools/objinfo $RPM_BUILD_ROOT%{_bindir}/ocamlobjinfo
+#install tools/objinfo $RPM_BUILD_ROOT%{_bindir}/ocamlobjinfo
 cp -r examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 ln -sf %{_libdir}/%{name}/{scrape,add}labels $RPM_BUILD_ROOT%{_bindir}
 
@@ -317,24 +314,32 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc Changes LICENSE README
+%doc Changes LICENSE README.adoc
 %attr(755,root,root) %{_bindir}/addlabels
 %attr(755,root,root) %{_bindir}/ocaml
-%attr(755,root,root) %{_bindir}/ocamlbuild*
 %attr(755,root,root) %{_bindir}/ocamlc
 %{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/ocamlc.*}
 %attr(755,root,root) %{_bindir}/ocamlcp
+%{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/ocamlcp.*}
 %attr(755,root,root) %{_bindir}/ocamldebug
-%attr(755,root,root) %{_bindir}/ocamldep*
-%attr(755,root,root) %{_bindir}/ocamldoc*
-%attr(755,root,root) %{_bindir}/ocamllex*
+%attr(755,root,root) %{_bindir}/ocamldep
+%{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/ocamldep.*}
+%attr(755,root,root) %{_bindir}/ocamldoc
+%{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/ocamldoc.*}
+%attr(755,root,root) %{_bindir}/ocamllex
+%{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/ocamllex.*}
 %attr(755,root,root) %{_bindir}/ocamlmklib
+%{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/ocamlmklib.*}
 %attr(755,root,root) %{_bindir}/ocamlmktop
+%{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/ocamlmktop.*}
 %attr(755,root,root) %{_bindir}/ocamlobjinfo
+%{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/ocamlobjinfo.*}
 %{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/ocamlopt}
 %{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/ocamlopt.*}
 %attr(755,root,root) %{_bindir}/ocamloptp
+%{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/ocamloptp.*}
 %attr(755,root,root) %{_bindir}/ocamlprof
+%{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/ocamlprof.*}
 %attr(755,root,root) %{_bindir}/ocamlyacc
 %attr(755,root,root) %{_bindir}/scrapelabels
 %{_includedir}/caml
@@ -352,7 +357,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/%{name}/ld.conf
 %{_libdir}/%{name}/camlheader
 %{_libdir}/%{name}/camlheader_ur
-%{_libdir}/%{name}/ocamlbuild
 %dir %{_libdir}/%{name}/ocamldoc
 %{_libdir}/%{name}/ocamldoc/*.hva
 %attr(755,root,root) %{_libdir}/%{name}/expunge
index aa4246b56ed67bcf801f37e009993f5019debb87..c46f1f388fe1a8b24ca970fd746474b7e8b98fdd 100644 (file)
--- a/x32.patch
+++ b/x32.patch
@@ -91,14 +91,3 @@ knowing anything about ocaml or the compiler, I preferred to keep it safe.
  }
  
  #define BNG_SETUP_OPS bng_ia32_setup_ops()
---- ocaml-4.02.1.orig/testsuite/makefiles/Makefile.common
-+++ ocaml-4.02.1/testsuite/makefiles/Makefile.common
-@@ -68,7 +68,7 @@ OCAMLMKLIB=$(OCAMLRUN) $(OTOPDIR)/tools/
- OCAMLYACC=$(TOPDIR)/yacc/ocamlyacc$(EXE)
- OCAMLBUILD=$(TOPDIR)/_build/ocamlbuild/ocamlbuild.native
- DUMPOBJ=$(OCAMLRUN) $(OTOPDIR)/tool/dumpobj
--BYTECODE_ONLY=[ "$(ARCH)" = "none" -o "$(ASM)" = "none" ]
-+BYTECODE_ONLY=[ "$(ARCH)" = "none" -o "$(ARCH)" = "x32" -o "$(ASM)" = "none" ]
- #FORTRAN_COMPILER=
- #FORTRAN_LIBRARY=
This page took 0.07008 seconds and 4 git commands to generate.