]> git.pld-linux.org Git - packages/ocaml-integers.git/blob - ocaml-integers.spec
- updated to 0.5.1
[packages/ocaml-integers.git] / ocaml-integers.spec
1 #
2 # Conditional build:
3 %bcond_without  ocaml_opt       # native optimized binaries (bytecode is always built)
4
5 # not yet available on x32 (ocaml 4.02.1), update when upstream will support it
6 %ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
7 %undefine       with_ocaml_opt
8 %endif
9
10 %if %{without ocaml_opt}
11 %define         _enable_debug_packages  0
12 %endif
13
14 Summary:        Various signed and unsigned integer types for OCaml
15 Summary(pl.UTF-8):      Różne typy całkowite ze znakiem i bez dla OCamla
16 Name:           ocaml-integers
17 Version:        0.5.1
18 Release:        1
19 License:        MIT
20 Group:          Libraries
21 #Source0Download: https://github.com/ocamllabs/ocaml-integers/releases
22 Source0:        https://github.com/ocamllabs/ocaml-integers/archive/%{version}/%{name}-%{version}.tar.gz
23 # Source0-md5:  24d629966763b4956edfb7e64d6c5427
24 URL:            https://github.com/ocamllabs/ocaml-integers
25 BuildRequires:  ocaml >= 1:4.02
26 BuildRequires:  ocaml-dune
27 %requires_eq    ocaml-runtime
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 The ocaml-integers library provides a number of 8-, 16-, 32- and
32 64-bit signed and unsigned integer types, together with aliases such
33 as "long" and "size_t" whose sizes depend on the host platform.
34
35 %description -l pl.UTF-8
36 Biblioteka ocaml-integers dostarcza wiele typów całkowitych, 8-, 16-,
37 32- i 64-bitowych, ze znakiem i bez, oraz aliasy, takie jak "long" czy
38 "size_t", których rozmiary zależą od platformy.
39
40 %package devel
41 Summary:        Development files for OCaml integers library
42 Summary(pl.UTF-8):      Pliki programistyczne biblioteki OCamla integers
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45 %requires_eq    ocaml
46
47 %description devel
48 This package contains libraries and signature files for developing
49 applications that use OCaml integers library.
50
51 %description devel -l pl.UTF-8
52 Ten pakiet zawiera biblioteki i pliki sygnatur do tworzenia aplikacji
53 wykorzystujących bibliotekę OCamla integers.
54
55 %prep
56 %setup -q
57
58 %build
59 dune build %{?_smp_mflags} --display=verbose
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 dune install --destdir=$RPM_BUILD_ROOT
65
66 # sources
67 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/integers{,/top}/*.ml
68 # packaged as %doc
69 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc/integers
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %files
75 %defattr(644,root,root,755)
76 %doc CHANGES.md LICENSE.md README.md
77 %dir %{_libdir}/ocaml/integers
78 %dir %{_libdir}/ocaml/integers/top
79 %{_libdir}/ocaml/integers/META
80 %{_libdir}/ocaml/integers/*.cma
81 %{_libdir}/ocaml/integers/top/*.cma
82 %if %{with ocaml_opt}
83 %attr(755,root,root) %{_libdir}/ocaml/integers/*.cmxs
84 %endif
85 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllintegers_stubs.so
86
87 %files devel
88 %defattr(644,root,root,755)
89 %{_libdir}/ocaml/integers/dune-package
90 %{_libdir}/ocaml/integers/opam
91 %{_libdir}/ocaml/integers/*.a
92 %{_libdir}/ocaml/integers/*.cmi
93 %{_libdir}/ocaml/integers/*.cmt
94 %{_libdir}/ocaml/integers/*.cmti
95 %{_libdir}/ocaml/integers/*.h
96 %{_libdir}/ocaml/integers/*.mli
97 %if %{with ocaml_opt}
98 %{_libdir}/ocaml/integers/*.cmx
99 %{_libdir}/ocaml/integers/*.cmxa
100 %endif
101 %{_libdir}/ocaml/integers/top/*.cmi
102 %{_libdir}/ocaml/integers/top/*.cmt
103 %{_libdir}/ocaml/integers/top/*.cmti
104 %{_libdir}/ocaml/integers/top/*.mli
This page took 0.093572 seconds and 4 git commands to generate.