]> git.pld-linux.org Git - packages/nuspell.git/blob - nuspell.spec
- updated to 5.1.3; don't build tests (fetching Catch2) while not running them
[packages/nuspell.git] / nuspell.spec
1 # TODO: catch2 >= 2.3.0 for tests, https://github.com/catchorg/Catch2.git
2 Summary:        Nuspell spell checking library
3 Summary(pl.UTF-8):      Biblioteka sprawdzania pisowni Nuspell
4 Name:           nuspell
5 Version:        5.1.3
6 Release:        1
7 License:        LGPL v3+
8 Group:          Libraries
9 #Source0Download: https://github.com/nuspell/nuspell/releases
10 Source0:        https://github.com/nuspell/nuspell/archive/v%{version}/%{name}-%{version}.tar.gz
11 # Source0-md5:  a0e833e8272327ddf66c3764d2176cfb
12 URL:            https://nuspell.github.io/
13 BuildRequires:  cmake >= 3.8
14 BuildRequires:  libicu-devel
15 # -std=c++17, std::from_chars
16 BuildRequires:  libstdc++-devel >= 6:8
17 BuildRequires:  rpmbuild(macros) >= 1.749
18 Requires:       %{name}-libs = %{version}-%{release}
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Nuspell is a spell checker library and command-line program designed
23 for languages with rich morphology and complex word compounding.
24 Nuspell is a pure C++ re-implementation of Hunspell.
25
26 Main features of Nuspell spell checker:
27 - Full unicode support backed by ICU
28 - Backward compatibility with Hunspell dictionary file format
29 - Twofold affix stripping (for agglutinative languages, like Azeri,
30   Basque, Estonian, Finnish, Hungarian, Turkish, etc.)
31 - Support complex compounds (for example, Hungarian and German)
32 - Support language specific features (for example, special casing of
33   Azeri and Turkish dotted i, or German sharp s)
34 - Handle conditional affixes, circumfixes, fogemorphemes, forbidden
35   words, pseudoroots and homonyms.
36 - Free software. Licensed under GNU LGPL v3.
37
38 %description -l pl.UTF-8
39 Nuspell to biblioteka i narzędzie linii poleceń do sprawdzania
40 pisowni, zaprojektowane dla języków o bogatej morfologii i złożonym
41 łączeniu słów. Nuspell jest reimplementacją Hunspella w czystym C++.
42
43 Główne cechy Nuspella:
44 - pełna obsługa Unicode oparta o ICU
45 - wsteczna zgodność z formatem plików słówników Hunspella
46 - dwukrotne usuwanie formantów (dla języków aglutynacyjnych, jak
47   azerski, baskijski, estoński, fiński, węgierski, turecki...)
48 - obsługa złożonego łączenia (języki np. węgierski, niemiecki)
49 - obsługa cech specyficznych dla języków (np. specjalne przypadki
50   azerskiego i tureckiego "i" z kropkami czy niemieckiego ß)
51 - obsługa formantów warunkowych, okołorostków, fogemorfemów, słów
52   zakazanych, pseudordzeni i homonimów
53 - oprogramowanie wolnodostępne, na licencji GNU LGPL v3
54
55 %package libs
56 Summary:        Nuspell spell checking library
57 Summary(pl.UTF-8):      Biblioteka sprawdzania pisowni Nuspell
58 Group:          Libraries
59
60 %description libs
61 Nuspell spell checking library.
62
63 %description libs -l pl.UTF-8
64 Biblioteka sprawdzania pisowni Nuspell.
65
66 %package devel
67 Summary:        Header files for Nuspell library
68 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Nuspell
69 Group:          Development/Libraries
70 Requires:       %{name}-libs = %{version}-%{release}
71 Requires:       libicu-devel
72 Requires:       libstdc++-devel >= 6:8
73
74 %description devel
75 Header files for Nuspell library.
76
77 %description devel -l pl.UTF-8
78 Pliki nagłówkowe biblioteki Nuspell.
79
80 %prep
81 %setup -q
82
83 %if 0%{_ver_lt "%{cc_version}" "9"}
84 %{__sed} -i -e '/target_link_libraries(nuspell/ s/)/ stdc++fs)/' src/nuspell/CMakeLists.txt
85 %endif
86
87 %build
88 install -d build
89 cd build
90 %cmake .. \
91         -DBUILD_TESTING=OFF
92
93 %{__make}
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97
98 %{__make} -C build install \
99         DESTDIR=$RPM_BUILD_ROOT
100
101 # packaged as %doc
102 %{__rm} $RPM_BUILD_ROOT%{_docdir}/README.md
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %post   libs -p /sbin/ldconfig
108 %postun libs -p /sbin/ldconfig
109
110 %files
111 %defattr(644,root,root,755)
112 %doc AUTHORS CHANGELOG.md README.md docs/Third-party_licenses
113 %attr(755,root,root) %{_bindir}/nuspell
114
115 %files libs
116 %defattr(644,root,root,755)
117 %attr(755,root,root) %{_libdir}/libnuspell.so.*.*.*
118 %attr(755,root,root) %ghost %{_libdir}/libnuspell.so.5
119
120 %files devel
121 %defattr(644,root,root,755)
122 %attr(755,root,root) %{_libdir}/libnuspell.so
123 %{_includedir}/nuspell
124 %{_pkgconfigdir}/nuspell.pc
125 %{_libdir}/cmake/nuspell
This page took 0.03456 seconds and 4 git commands to generate.